Re: How do you specify a rubygem is being required?

Glad that was helpful!

Al

----- Original Message ----
From: Ashley M. [email protected]
To: rspec-users [email protected]
Sent: Thursday, October 25, 2007 12:01:11 PM
Subject: Re: [rspec-users] How do you specify a rubygem is being
required?

On Oct 25, 2007, at 3:08 am, Al Chou wrote:

I believe the current version uses the “gem” method and deprecates
the “require” method. Rails warns me about something to that
effect whenever I run script/server, anyway.

Not that I seem to have given you any real help with your spec
question…

Actually no, you were spot on! Using gem allows me to write
Kernel.gem / Kernel.should_receive(:gem) etc.

Thanks!
Ashley


blog @ http://aviewfromafar.net/
linked-in @ http://www.linkedin.com/in/ashleymoran
currently @ home


rspec-users mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/rspec-users

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs