Re: Help please - install openSUSE 11.1 gnuradio

Sorted…

gnuradio install - openSUSE 11.1 Linux version 2.6.27.7-9-pae

  1. gcc - YAST
  2. python and python devel - YAST
  3. SWIG - YAST
  4. FFTW3F -devel YAST
  5. libccpunit - YAST
  • installed gcc43-c++ (missing g++ error) (YAST)
  • Downloaded and installed boost_1_42_0 .tar.gz

BOOST_PREFIX=/opt/boost_1_35
./bootstrap.sh --prefix=$BOOST_PREFIX

(bootstrap.sh and bjam install)

Getting there …


The following GNU Radio components have been successfully configured:

config
gruel
omnithread
usrp2
docs

You my now run the make command to build these components.


The following components were skipped either because you asked not
to build them or they didn’t pass configuration checks:

gcell
gnuradio-core
pmt
mblock
usrp
gr-usrp
gr-usrp2
gr-gcell
gr-audio-alsa
gr-audio-jack
gr-audio-oss
gr-audio-osx
gr-audio-portaudio
gr-audio-windows
gr-cvsd-vocoder
gr-gpio
gr-gsm-fr-vocoder
gr-pager
gr-radar-mono
gr-radio-astronomy
gr-trellis
gr-video-sdl
gr-wxgui
gr-qtgui
gr-sounder
gr-utils
gnuradio-examples
grc

These components will not be built.

----- Original Message -----
From: Andrew R.
To: gnuradio
Sent: Friday, March 19, 2010 7:28 PM
Subject: Help please - install

Hello

I am installing gnuradio on openSUSE.

I got this far and then got stuck:-

  1. gcc - YAST
  2. python and python devel - YAST
  3. SWIG - YAST
  4. FFTW3F -devel YAST
  5. ccpunit - YAST
  6. I am now stuck on “boost” as part of the configure. (it is in YAST
    but stops)

checking for boost >= 1.35… no
configure: error: we could not detect the boost libraries (version
1.35 or higher).
If you are sure you have boost installed, then check your version
number looking in <boost/version.hpp>.

Andrew

Andrew,

It seems you are still missing a lot of dependencies, you can see a
list here: http://gnuradio.org/redmine/wiki/gnuradio/SuseInstall
On desktop linux distributions you should be able to have everything
enabled except

gcell
gr-gcell
gr-audio-osx
gr-audio-windows
gr-comedi
and possibly jack and portaudio.

Alex

Thanks Alex

I forgot about that page, talk about doing things the long way around !

I installed and got:-


The following GNU Radio components have been successfully configured:

config
gruel
omnithread
gnuradio-core
pmt
mblock
usrp2
gr-usrp2
gr-audio-alsa
gr-audio-jack
gr-audio-oss
gr-cvsd-vocoder
gr-gsm-fr-vocoder
gr-pager
gr-radio-astronomy
gr-trellis
gr-video-sdl
gnuradio-examples
docs

You my now run the make command to build these components.


The following components were skipped either because you asked not
to build them or they didn’t pass configuration checks:

gcell
usrp
gr-usrp
gr-gcell
gr-audio-osx
gr-audio-portaudio
gr-audio-windows
gr-gpio
gr-radar-mono
gr-wxgui
gr-qtgui
gr-sounder
gr-utils
grc

These components will not be built.

----- Original Message -----
From: “Alexandru C.” [email protected]
To: “gnuradio” [email protected]
Sent: Friday, March 19, 2010 9:14 PM
Subject: Re: [Discuss-gnuradio] Re: Help please - install openSUSE 11.1
gnuradio

Andrew,

It seems you are still missing a lot of dependencies, you can see a
list here: http://gnuradio.org/redmine/wiki/gnuradio/SuseInstall
On desktop linux distributions you should be able to have everything
enabled except

gcell
gr-gcell
gr-audio-osx
gr-audio-windows
gr-comedi
and possibly jack and portaudio.

Alex

On 19 March 2010 11:48, Andrew R. [email protected] wrote:

  • installed gcc43-c++ (missing g++ error) (YAST)
    The following GNU Radio components have been successfully configured:
    The following components were skipped either because you asked not
    gr-audio-alsa
    gr-radio-astronomy

To: gnuradio
3) SWIG - YAST

Andrew


Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

On Fri, Mar 19, 2010 at 8:15 AM, Andrew R. [email protected]
wrote:

gruel
gr-gsm-fr-vocoder
The following components were skipped either because you asked not
gr-radar-mono
gr-wxgui
gr-qtgui
gr-sounder
gr-utils
grc

These components will not be built.

Andrew,

With the configure script, you can always add a “–enable-gr-usrp” or
any other component. This will force the configure script to
explicitly check that those components can be installed. If they
can’t, it will immediately exit and you can see the error that caused
the exit.

Of this group that you have listed that will not be installed, the
important ones are gr-usrp and gr-wxgui, which will allow gr-utils to
be installed. For gr-usrp, you probably need SDCC installed and for
gr-wxgui you’ll need wxPython and wxGui.

Tom

On a fresh openSUSE 11.2, if have installed gnuradio a few days ago.
After the installation, rpm -qa --last gave me
python-Cheetah-2.4.0-1.3 So 21 Mär 2010 23:41:46 CET
python-lxml-2.2.2-2.1 So 21 Mär 2010 23:38:17 CET
python-wxGTK-2.8.10.1-2.pm.3.1 So 21 Mär 2010 23:33:44 CET
wxWidgets-2.8.10.1-2.pm.3.1 So 21 Mär 2010 23:28:36 CET
libmspack0-0.0.20060920alpha-69.2 So 21 Mär 2010 23:28:35 CET
sdcc-devel-2.7.0-3.1 So 21 Mär 2010 23:18:49 CET
sdcc-2.7.0-3.1 So 21 Mär 2010 23:18:47 CET
libusb-compat-devel-0.1.3-2.2 So 21 Mär 2010 23:13:11 CET
libSDL-devel-1.2.13-112.3 So 21 Mär 2010 23:08:38 CET
guile-1.8.6-2.3 So 21 Mär 2010 23:08:37 CET
alsa-devel-1.0.21-3.2 So 21 Mär 2010 23:08:37 CET
libqwt-devel-5.2.0-0.pm.3.1 So 21 Mär 2010 23:05:48 CET
libqwt5-5.2.0-0.pm.3.1 So 21 Mär 2010 23:05:48 CET
libqwtplot3d-devel-0.2.7-0.pm.4.1 So 21 Mär 2010 23:05:25 CET
libqwtplot3d0-0.2.7-0.pm.4.1 So 21 Mär 2010 23:05:24 CET
libusb-1_0-devel-1.0.2-2.2 So 21 Mär 2010 23:04:23 CET
gsl-devel-1.12-2.2 So 21 Mär 2010 23:02:35 CET
gsl-1.12-2.2 So 21 Mär 2010 23:02:34 CET
libcppunit-devel-1.12.0-93.2 So 21 Mär 2010 23:00:32 CET
libcppunit-1_12-0-1.12.0-93.2 So 21 Mär 2010 23:00:30 CET
doxygen-1.5.9-3.2 So 21 Mär 2010 22:59:58 CET
fftw3-threads-devel-3.2.2-2.2 So 21 Mär 2010 22:58:02 CET
fftw3-devel-3.2.2-2.2 So 21 Mär 2010 22:57:47 CET
fftw3-threads-3.2.2-2.2 So 21 Mär 2010 22:57:46 CET
gcc-fortran-4.4-4.2 So 21 Mär 2010 22:56:56 CET
gcc44-fortran-4.4.1_20090817-2.3.4 So 21 Mär 2010 22:56:55 CET
python-devel-2.6.2-6.3 So 21 Mär 2010 22:56:14 CET

Before I have upgraded to 11.2, I used 11.1 as well… so it has to
work. Please note, that some of the packages above are not in the
standard repositories: You should use the appropriate repository from
the OBS.

Regards,
Gregor

2010/3/22 Tom R. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs