Re: followup: libgnuradio-fcd-3.7.3git.so.0.0.0: undefined reference to `libusb_handle_events_comple

On Jan. 8, 2013, George wrote:

Same problem with libfaad2, fix recipe, and fix the cmake file that
set up where to look for both header files and library.
That was your solution also?

Hate to admit, was in a hurry so I just nuked the system library copy,
and replaced it with the ones that pybombs compiled. That worked, but
not anywhere near as cleanly as the solution you’ve outlined… :-/

Best

Max

On 01/08/2014 06:17 PM, ikjtel wrote:

On Jan. 8, 2013, George wrote:

Same problem with libfaad2, fix recipe, and fix the cmake file that
set up where to look for both header files and library.
That was your solution also?

Hate to admit, was in a hurry so I just nuked the system library copy,
and replaced it with the ones that pybombs compiled. That worked, but
not anywhere near as cleanly as the solution you’ve outlined… :-/

Did not work the way I expected either, had to uninstall the system
variant before cmake found that it could actually use the variant I put
first.
I reran from cmake, but it resolved to the system header files and lib,
and I don’t understand why.
The recipe is included below, while the cmake file is here:
https://github.com/rfz-com/gr-drm/commit/0f062bb97b1e742b829260653418c64520c4ee1d

faad2.lwr

category: baseline
source: wget://http://downloads.sourceforge.net/faac/faad2-2.7.tar.gz
satisfy_deb: libfaad-dev
#satisfy_rpm: faad2-devel
configure {
. bootstrap
./configure --without-xmms --with-drm --without-mpeg4ip --with-pic
}
install {
make
cp include/faad.h include/neaacdec.h $prefix/include
cp libfaad/.libs/libfaad.a $prefix/lib
cp libfaad/.libs/libfaad.a $prefix/lib64
}

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs