Re: EXCEPTION_ACCESS_VIOLATION since 1.1.3

I was using json-jruby-1.1.2-universal-java-1.6. Removing it solved the
problem. Excuse me for the noise.

----- Original Message ----
From: P Heemskerk [email protected]
To: [email protected]
Sent: Sunday, July 27, 2008 9:24:28 AM
Subject: [jruby-user] EXCEPTION_ACCESS_VIOLATION since 1.1.3

Hi,

The update to 1.1.3 breaks my application:

An unexpected error has been detected by Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d8a1392, pid=5132,

tid=5492

Java VM: Java HotSpot™ Client VM (10.0-b23 mixed mode, sharing

windows-x86)

Problematic frame:

V [jvm.dll+0x31392]

and I see this is in hs_err_pid5132:

Current CompileTask:
C1:2867
!
ruby.jit.ruby.C_3a_.jruby_minus_1_dot_1_dot_3.lib.ruby.$1_dot_8.rexml.parsers.streamparser.parse30311837_10994782.rescue_1$RUBY$rescue(Lorg/jruby/runtime/ThreadContext;Lorg/jruby/runtime/builtin/IRubyObject;Lorg/jruby/runtime/Block;)Lorg/jruby/runtime/builtin/IRubyObject;
(1957 bytes)

Java version is 1.6.0 update 7 on Vista x86. This problem doesn’t occur
with 1.1.2 or older releases. Any suggestions?

Thanks!


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs