Re: error compiling gnuradio trunk


#1

I found out that

AC_PROG_MKDIR_P is defined only on autoconf 2.60, while
gnuradio requires only autoconf 2.57 and above.

After a google search, I found this patch:

AC_PROG_MKDIR_P

is a backport of autoconf-2.60’s AC_PROG_MKDIR_P.

Remove this macro when we can assume autoconf >= 2.60.

m4_ifdef([AC_PROG_MKDIR_P], [], [
AC_DEFUN([AC_PROG_MKDIR_P],
[AC_REQUIRE([AM_PROG_MKDIR_P])dnl defined by automake
MKDIR_P=’$(mkdir_p)’
AC_SUBST([MKDIR_P])])])
AC_PROG_MKDIR_P

I put this in the configure.ac file and it seems that it works now.

I have no idea about these programs, so can someone apply this/or a more
appropriate fix.

Thanks
Achilleas

====================================================
After a bit of searching I think the problem is as follows:

Since AC_PROG_MKDIR_P is reported undefined, this propagates to the
corresponding Makefiles,

eg in

gnuradio-corse/docs/Makefile

which contains the line

MKDIR_P =

so later on when it tries to execute

$(MKDIR_P) html

in order to create the html directory it executes instead

html

thus the error in make.

So my question is now, why in the first place this happens, and
secondly,
what is the best way to fix it.

Thanks
Achilleas

I am trying to install gnuradio from trunk to a
“Red Hat Enterprise Linux WS release 5 (Tikanga)”

Bootstrap gives the following error:

configure.ac:85: error: possibly undefined macro: AC_PROG_MKDIR_P
If this token and others are legitimate, please use
m4_pattern_allow.
See the Autoconf documentation.

Then configure executes with the following error messages

caen-vnc04% ./myconf > foo.log
./configure: line 5091: AC_PROG_MKDIR_P: command not found
pgf77-Error-Unknown switch: -print-search-dirs
configure: WARNING: If you wanted to set the --build type, don’t use
–host.
If a cross compiler is detected then cross compile mode will be
used.

Finally, make stops with the following message:

make[4]: Entering directory
/afs/umich.edu/user/a/n/anastas/gnuradio_trunk_test/gnuradio-core/doc' html make[4]: html: Command not found make[4]: *** [prep] Error 127 make[4]: Leaving directory/afs/umich.edu/user/a/n/anastas/gnuradio_trunk_test/gnuradio-core/doc’
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
/afs/umich.edu/user/a/n/anastas/gnuradio_trunk_test/gnuradio-core/doc' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory/afs/umich.edu/user/a/n/anastas/gnuradio_trunk_test/gnuradio-core’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/afs/umich.edu/user/a/n/anastas/gnuradio_trunk_test’
make: *** [all] Error 2

I don’t know why “html” is needed or what it is, but apparently cannot
be found.

Any ideas?

Achilleas


#2

On Mon, May 04, 2009 at 03:37:05PM -0400, Achilleas A.
wrote:

m4_ifdef([AC_PROG_MKDIR_P], [], [

Thanks
Achilleas

Achilleas,

Thanks for sorting this out. Johnathan or I will make sure that it
gets into the trunk and the 3.2 release.

Eric


#3

On Mon, May 4, 2009 at 12:56 PM, Eric B. removed_email_address@domain.invalid wrote:

On Mon, May 04, 2009 at 03:37:05PM -0400, Achilleas A. wrote:

I found out that

AC_PROG_MKDIR_P is defined only on autoconf 2.60, while
gnuradio requires only autoconf 2.57 and above.

After a google search, I found this patch:

Thanks for sorting this out. Johnathan or I will make sure that it
gets into the trunk and the 3.2 release.

This has been applied to the trunk as of r11001. Thanks.

Johnathan