Re: CVS build problem with shared_ptr.hpp

I was trying using ./configure command for compiling GNU Radio on Cygwin
and
received following error message:

gr_boost_include_dir = /usr/include/boost-1_33_1/boost/
checking boost/shared_ptr.hpp usability… no
checking boost/shared_ptr.hpp presence… no
checking for boost/shared_ptr.hpp… no
configure: error: Failed to locate boost/shared_ptr.hpp.
Try using --with-boost-include-dir=,
E.g., --with-boost-include-dir=/usr/local/include/boost-1_33_1

The include directory for the Boost is OK, even then I am facing a
problem.
Please suggest me how to solve this problem. I tried using following
command
:

$ ./configure --enable-maintainer-mode
–with-boost-include-dir=/usr/include/boost-1_33_1/boost/

But there is no improvement. Can some one help me in this regard?

Thank you
Tarun

On Thu, Oct 05, 2006 at 06:37:36PM -0500, Tarun T. wrote:

Thank you
Tarun

Not sure if this is still a problem, but you’d want this:

$ ./configure --enable-maintainer-mode
–with-boost-include-dir=/usr/include/boost-1_33_1

Note carefully the path.

Eric

“-with-boost-include-dir=/usr/include/boost-1_33_1/” worked for me.

I got a little farther on a cygwin build, and ran into a problem
buliding the libs. I’ve included a short snippet of the make output.
I think CppUnit may be installed wrong.

Any ideas?

make[5]: Entering directory
/d/home/bvincent/gnuradio/gnuradio-3.0/gnuradio-core/src/lib' /bin/sh ../../../libtool --tag=CXX --mode=link g++ -g -O2 -Wall -Woverloaded-virtual -o libgnuradio-core-qa.la -rpath /usr/local/lib -no-undefined -version-info 0:0:0 "-Wl,--enable-runtime-pseudo-reloc" bug_work_around_6.lo filter/libfilter-qa.la general/libgeneral-qa.la runtime/libruntime-qa.la missing/libmissing.la libgnuradio-core.la -lcppunit -lwinmm rm -fr .libs/libgnuradio-core-qa.dll.a g++ -shared -nostdlib .libs/bug_work_around_6.o -Wl,--whole-archive filter/.libs/libfilter-qa.a general/.libs/libgeneral-qa.a runtime/.libs/libruntime-qa.a missing/.libs/libmissing.a -Wl,--no-whole-archive ./.libs/libgnuradio-core.dll.a -L/usr/lib /usr/lib/libcppunit.dll.a -lwinmm -L/usr/lib/gcc/i686-pc-cygwin/3.4.4 -L/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../.. -lstdc++ -lgcc -lcygwin -luser32 -lkernel32 -ladvapi32 -lshell32 -lgcc -Wl,--enable-runtime-pseudo-reloc -o .libs/cyggnuradio-core-qa-0.dll -Wl,--enable-auto-image-base -Xlinker --out-implib -Xlinker .libs/libgnuradio-core-qa.dll.a filter/.libs/libfilter-qa.a(qa_filter.o): In function_ZN9qa_filter5suiteEv’:
/d/home/bvincent/gnuradio/gnuradio-3.0/gnuradio-core/src/lib/filter/./qa_gri_mmse_fir_interpolator.h:30:
undefined reference to
CppUnit::TestSuiteBuilderContextBase::~TestSuiteBuilderContextBase()' /d/home/bvincent/gnuradio/gnuradio-3.0/gnuradio-core/src/lib/filter/./qa_gri_mmse_fir_interpolator.h:32: undefined reference toCppUnit::TestSuiteBuilderContextBase::~TestSuiteBuilderContextBase()’
filter/.libs/libfilter-qa.a(qa_filter.o): In function
`_ZN9qa_filter5suiteEv’:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs