Re: config.gem dependencies broken?


#1

Hi Joerg,

This is a real bug and it has been solved. See the following thread.
http://groups.google.com/group/rubyonrails-core/browse_thread/thread/73f21c47d114b88e

To solve the problem apply the patch on:
http://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/1464

The shortcut way is to add a line to:
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb

def dependencies
  return [] if framework_gem?
  return [] if specification.nil? # <= THE NEW LINE
  all_dependencies = specification.dependencies.map do |dependency|

Hopefully soon there will be an updated gem.

Have fun,

Sander

You have a nil object when you didn’t expect it!
The error occurred while evaluating nil.dependencies
/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/rails/gem_dependency.rb:
77:in `dependencies’

View this message in context:
http://www.nabble.com/config.gem-dependencies-broken--tp20770884p20784620.html
Sent from the RubyOnRails Users mailing list archive at Nabble.com.


#2

Sander,

ahhh I see… thank you. I could workaround this issue by explicitely
specifiying each of my gems dependencies before the actual gems:

http://blogwi.se/post/62475715/rails-2-2-your-gems-gems-want-to-be-mentioned-aswell

-J