Re: benchmark_ofdm_rx not working

On 10/22/07, [email protected] <
[email protected]> wrote:

To: GNU Radio D. [email protected]

are printed in that function).
is a --tx-amplitude flag to adjust this. Set it to 2000 - 4000.



I increased the amplitude to around 3000 on the tx usrp. I also ran the on the rx side. I could observe the spectrum of the rx
which was around 30 dB. So I know that the rx side usrp is able to
the packets trasnmitted. However, now when I run the
script on the rx side, I do not see any output. The output that I get is

After rx_callback( ) definition

gr_fir_ccf: using SSE
gr_fir_fff: using SSE
INIT Completed Successfully!!!
fg=usrp_graph(…) called (comment added for debugging)
gr_buffer::allocate_buffer: warning: tried to allocate
20 items of size 1600. Due to alignment requirements
64 were allocated. If this isn’t OK, consider padding
your structure to a power-of-two bytes.
On this platform, our allocation granularity is 4096 bytes.
fg.start() (comment added for debugging)
Inside RX _Callback pktno (comment added for debugging)
ok: False pktno: 58626 n_rcvd: 1 n_right: 0

Only one packet is received after a long time. Could you suggest as
why the output is not displayed?

Archana Ragothaman
Master’s in Telecommunications
Graduate Research Assistant
University of Maryland, College Park
Email: remove[email protected]
Phone: 240-422-7887

Archana Ragothaman wrote:

> am executing are
> However the script does not give any output. I
usrp_fft to

INIT Completed Successfully!!!
Only one packet is received after a long time. Could you suggest as
to why the output is not displayed?

Try decreasing the bandwidth by increasing the interpolation and
decimation rates (and make sure the decimation is half the interpolation
value you use). The OFDM system takes quite a lot of resources right now
to run, so slowing things down may help.

Unfortunately, the output you’ve displayed there isn’t really showing
anything wrong except you’re not getting any packets. There’s little to
go on to help you debug it. Try to run in verbose mode (-v), which will
output all of the settings of the (de)modulator.