Rdoc_osx_dictionary 1.1.0 Released

rdoc_osx_dictionary version 1.1.0 has been released!

rdoc via Apple’s Dictionary.app. Automatically builds and installs an
Apple Dictionary with all rdoc nicely formatted.

Changes:

1.1.0 / 2010-02-01

  • 2 minor enhancements:

    • Added -f to force rebuild.
    • Refactored system calls to a handler so failures are uniformly
      handled.
  • 2 bug fixes:

    • Fixed dictionary entry id munging to avoid errant duplicates.
    • Setting $LC_ALL to C to fix unicode errors discovered in iTerm.
  • Fixed dictionary entry id munging to avoid errant duplicates.
  • Setting $LC_ALL to C to fix unicode errors discovered in iTerm.

Hi,

Thanks for the new release.

But unfortunately I got some troubles, with 1.8.7 and 1.9.2:

On 1.9.2, it just failed the installation:
New entries for dictionary. Rebuilding dictionary.

  • Building RubyAndGems.dictionary. […]
  • Preparing index data.
    *** Duplicate entry_id: [module_RDoc__Generator__MarkUp] at
    /Developer/Extras/Dictionary Development
    Kit/bin/replace_entryid_bodyid.plline 88, <ENTRY_TO_BODY> line 7934.
    Error.
    command failed

On 1.8.7, it installed successfully, but I didn’t get any core
class(like
String, Array, Hash, …), only the gems docs.
Do I need to rdoc the core before in any way? Please excuse my ignorance
if
it is.
(Also, the rdoc last-version gem doesn’t play nicely with
1.8.7(undefined
method `merge_in’ for #YAML::Object ) )

  • Building RubyAndGems.dictionary. […]
  • Preparing index data.
    ** Note: Null key text. Skipped line [ 287343 0 -
    Nokogiri___XML___NodeSet#_minus].
  • Duplicate index. Skipped [config 1162 0 Config ]
  • Duplicate index. Skipped [gem 1726 0 Gem ]
  • Duplicate index. Skipped [gemgauntlet 182819 0 GemGauntlet
    ]
  • Duplicate index. Skipped [kernel 183855 0 Kernel ]
  • Duplicate index. Skipped [nokogiri 186208 0 Nokogiri
    ]
  • Duplicate index. Skipped [object 315299 0 Object ]
  • Duplicate index. Skipped [string 664938 0 String ]
  • Duplicate index. Skipped [struct 665369 0 Struct ]
  • Duplicate index. Skipped [tempio 666190 0 TempIO ]
  • Building key_text index.
    ** Note: Null key text. Skipped line [ 287343 0 -
    Nokogiri___XML___NodeSet#_minus].
  • Building reference index. […]
  • Finished building objects/RubyAndGems.dictionary.
    installing
    installed
    Run Dictionary.app to use the new dictionary. (activate in prefs!)

Regards,
B.D.

On 2 February 2010 12:04, Benoit D. [email protected] wrote:

On 1.8.7, it installed successfully, but I didn’t get any core class(like
String, Array, Hash, …), only the gems docs.

Sorry, apparently I didn’t have any share/ri dir with my core classes,
weared. RVM looks like not installing the ri in 1.8.7.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs