Rdoc hoe dependency

For the benefit of us nubies, maybe rdoc should also update hoe if it
finds it at lower version (cause otherwise it should not install since
it would not run anyway). just a suggestion.

eg

[email protected]:/usr/local/src/ruby-1.8.7-p71$ rdoc --all --ri
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:578:in
report_activate_error': RubyGem version error: hoe(1.6.0 not >= 1.7.0) (Gem::LoadError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:134:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:158:in
activate' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:157:ineach’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:157:in
activate' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:49:ingem’
from /usr/local/bin/rdoc:18

[email protected]:/usr/local/src/ruby-1.8.7-p71$ sudo gem install hoe
[sudo] password for botp:
Successfully installed hoe-1.7.0
1 gem installed
Installing ri documentation for hoe-1.7.0…
Installing RDoc documentation for hoe-1.7.0…

[email protected]:/usr/local/src/ruby-1.8.7-p71$ rdoc --all --ri
… works fine now…

kind regards -botp

On Aug 8, 2008, at 21:57 , Peña, Botp wrote:

For the benefit of us nubies, maybe rdoc should also update hoe if
it finds it at lower version (cause otherwise it should not install
since it would not run anyway). just a suggestion.

huh?

rdoc shouldn’t update hoe or any other gem. Rubygems should…

What I don’t understand is how you installed a newer rdoc that
requires a newer hoe, but somehow didn’t update hoe. Either something
messed up with your install and dependencies weren’t updated (usually
they’re first tho) or… I have no idea.

Actually… this is odd:

dependencies:

  • !ruby/object:Gem::Dependency
    name: hoe
    type: :development
    version_requirement:
    version_requirements: !ruby/object:Gem::Requirement
    requirements:
      • “>=”
      • !ruby/object:Gem::Version
        version: 1.7.0
        version:

hoe is a developer dependency, so it shouldn’t be activated when you
use the rdoc cmdline tool. I think you might have a mix of rdoc
versions?

On Sat, Aug 9, 2008 at 3:27 PM, Ryan D. [email protected]
wrote:

type: :development
version_requirement:
version_requirements: !ruby/object:Gem::Requirement
requirements:

    • “>=”
    • !ruby/object:Gem::Version
      version: 1.7.0
      version:

hoe is a developer dependency, so it shouldn’t be activated when you use the
rdoc cmdline tool. I think you might have a mix of rdoc versions?

Well well, thats not my experience at all, very strangely, gems that
have hoe as build dependency end up requiring hoe, when I try to
require the gem. In many cases, i had to edit the gemspec, to remove
hoe as dependency.

On Aug 8, 2008, at 21:57 PM, Peña, Botp wrote:

For the benefit of us nubies, maybe rdoc should also update hoe if
it finds it at lower version (cause otherwise it should not install
since it would not run anyway). just a suggestion.

I think it is RubyGems’ bug that has since been fixed.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs