Rdoc da gem o da pacchetto?


#1

usate la gemma rdoc oppure, per chi usa debian, lo installate da deb
assieme a ruby, ruby-dev, e irb?


#2

2009/2/24 Mauro removed_email_address@domain.invalid:

usate la gemma rdoc oppure, per chi usa debian, lo installate da deb
assieme a ruby, ruby-dev, e irb?

la seconda che hai detto
michele.


#3

2009/2/25 Michele F. removed_email_address@domain.invalid:

2009/2/24 Mauro removed_email_address@domain.invalid:

usate la gemma rdoc oppure, per chi usa debian, lo installate da deb
assieme a ruby, ruby-dev, e irb?

la seconda che hai detto

Cosi’ ho fatto anche io, poi ho installato rubygem scaricato da
rubyforge e successivamente installato le gemme rails e postgres.
Ora…da console lancio ri e mi dice comando non trovato, come mai?


#4

2009/2/25 Mauro removed_email_address@domain.invalid:

Se invece uso rdoc da gem tutto a posto…


#5

Il 26 febbraio 2009 9.14, Mauro removed_email_address@domain.invalid ha scritto:

Ora…da console lancio ri e mi dice comando non trovato, come mai?
è semplicemente questione di path, ora non ricordo (purtroppo, con
rails sto lavorando principalmente da windows). vedi dov’è ri e metti
quella dir nel path.

anzi, meglio ancora: segnala il bug.

pietro


#6

2009/2/26 Pietro G. removed_email_address@domain.invalid:

rubyforge e successivamente installato le gemme rails e postgres.
Ora…da console lancio ri e mi dice comando non trovato, come mai?

è semplicemente questione di path, ora non ricordo (purtroppo, con
rails sto lavorando principalmente da windows). vedi dov’è ri e metti
quella dir nel path.

anzi, meglio ancora: segnala il bug.

Allora la questione e’ questa.
Se installi rdoc da pacchetto e successivamente rubygem da sorgente
quest’ultimo ti cancella rdoc e ri, percio’ devi riinstallarli.
A questo punto visto che si sa che i pacchetti debian non sono proprio
aggiornatissimi e visto che di rdoc esiste la gemma penso sia
preferibile installare quest’ultima.