Rdiscount Deadlock!

rdiscount-1.3.1.1 is uninstallable on solaris


[email protected]:/opt/gitorious# gem install rdiscount -v 1.3.1.1
Building native extensions. This could take a while…
ERROR: Error installing rdiscount:
ERROR: Failed to build gem native extension.

/opt/ruby/bin/ruby extconf.rb
checking for random()… yes
checking for srandom()… yes
checking for funopen()… no
checking for fopencookie()… no
extconf.rb:11: No funopen or fopencookie support available.
(RuntimeError)

so I have installed rdiscount-1.3.4

and

rake db:migrate for gitorious wants rdiscount = 1.3.1.1


[email protected]:/opt/gitorious# rake db:migrate
(in /opt/gitorious)
Missing these required gems:
rdiscount = 1.3.1.1

You’re running:
ruby 1.8.7.72 at /opt/ruby/bin/ruby
rubygems 1.3.2 at /home/marya/.gem/ruby/1.8,
/opt/ruby/lib/ruby/gems/1.8

is there someway to bypass version check ?

i tried to make symlink of rdiscount-1.3.4 to rdiscount-1.3.1.1 and
upadted rdiscount.gemspec with ver 1.3.1.1

but still rake db:migrate gives error for rdiscount-1.3.1.1

Missing these required gems:
rdiscount = 1.3.1.1

comment out the line that requires this gem version :slight_smile:
?
=r

On Jul 9, 3:04 am, Manish A. [email protected]
wrote:

checking for srandom()… yes
rake db:migrate for gitorious wants rdiscount = 1.3.1.1
/opt/ruby/lib/ruby/gems/1.8

is there someway to bypass version check ?

i tried to make symlink of rdiscount-1.3.4 to rdiscount-1.3.1.1 and
upadted rdiscount.gemspec with ver 1.3.1.1

I wouldn’t recommend doing that - it’s not recommended, nor is it
correct.

Looking over the gitorious source, the config/environment.rb file
specifically requires that version. A quick scan of the rdiscount
source history shows that the most notable changes made between
1.3.1.1 and 1.3.4 were moving up the underlying Discount version and
correcting the issue with funopen you’ve run into above. Just fix the
line in environment.rb and things should be fine.

–Matt J.

sorry for late reply

I rebuild rdiscount after changing “s.version = ‘1.3.1.1’” in
rdiscount.gemspec file.

this fooled gitorious while version check :wink:

Regards,
-Manish

Matt J. wrote:

On Jul 9, 3:04�am, Manish A. [email protected]
wrote:

checking for srandom()… yes
rake db:migrate for gitorious wants �rdiscount �= 1.3.1.1
/opt/ruby/lib/ruby/gems/1.8

is there someway to bypass version check ?

i tried to make symlink of rdiscount-1.3.4 to rdiscount-1.3.1.1 and
upadted rdiscount.gemspec with ver 1.3.1.1

I wouldn’t recommend doing that - it’s not recommended, nor is it
correct.

Looking over the gitorious source, the config/environment.rb file
specifically requires that version. A quick scan of the rdiscount
source history shows that the most notable changes made between
1.3.1.1 and 1.3.4 were moving up the underlying Discount version and
correcting the issue with funopen you’ve run into above. Just fix the
line in environment.rb and things should be fine.

–Matt J.

Is there some reason that you can’t just fix the config.gem line in
Gitorious’s environment.rb?

Seriously, the next developer on the project is going to be severely
confused…

–Matt J.

On Jul 17, 4:27 am, Manish A. [email protected]

yea, because in environment.rb its clearly mentioned

config.gem “rdiscount”, :version => “1.3.1.1”

but at the time of installing rdiscount it wants

version = “1.3.1.1”

Matt J. wrote:

Is there some reason that you can’t just fix the config.gem line in
Gitorious’s environment.rb?

Seriously, the next developer on the project is going to be severely
confused…

–Matt J.

On Jul 17, 4:27�am, Manish A. [email protected]

On Jul 19, 11:04 pm, Manish A. [email protected]
wrote:

yea, because in environment.rb its clearly mentioned

config.gem “rdiscount”, :version => “1.3.1.1”

but at the time of installing rdiscount it wants

version = “1.3.1.1”

Were you expecting something else? That’s what the config.gem line
means. Changing it to:

config.gem ‘rdiscount’, :version => ‘>= 1.3.1.1’

will work, as will

config.gem ‘rdiscount’, :version => ‘1.3.4’

–Matt J.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs