Rbgccxml / rbplusplus gem dependency on hpricot question

Dear all,

I am having problems installing the rbgccxml gem on ubuntu 8.04, I get a
runtime error saying that
hpricot version=0.6 is required.
Now I had hpricot installed, as a gem, but it is version 0.6.161 .
Is there any special reason why these two should not work together ?

Thank you very much,

Best regards,

Axel

On Friday 15 August 2008 09:04:56 Axel E. wrote:

Dear all,

I am having problems installing the rbgccxml gem on ubuntu 8.04, I get a
runtime error saying that
hpricot version=0.6 is required.

Sounds like the same problem that rfeedparser has.

The explanation I got was, 0.6.161 is probably fine, but hadn’t been
tested,
and they didn’t want to allow 0.6 or higher, because that would imply a
future 0.7, which might actually break stuff.

In other words, someone very probably didn’t know about the gem ~>
specification.

Talk to the author of rbgccxml, and see if they’d be willing to
require “~>0.6” (or would that be “~>0.6.0”?), instead of “=0.6”.

The maintainer of rbgccxml is on vacation until next week. Feel free to
contact him after that, and I’m sure he’ll give you a speedy response.
He’s
a good guy: http://github.com/jameskilton

/Shawn

-------- Original-Nachricht --------

Datum: Sat, 16 Aug 2008 05:47:24 +0900
Von: “Shawn A.” [email protected]
An: [email protected]
Betreff: Re: rbgccxml / rbplusplus gem dependency on hpricot question

The maintainer of rbgccxml is on vacation until next week. Feel free to
contact him after that, and I’m sure he’ll give you a speedy response.
He’s
a good guy: http://github.com/jameskilton

/Shawn

Thanks for the info. I’ll do that.

Best regards,

Axel

On Fri, Aug 15, 2008 at 5:37 PM, Axel E. [email protected] wrote:

a good guy: http://github.com/jameskilton
http://games.entertainment.gmx.net/de/entertainment/games/free/puzzle/6169196

Thanks for pointing this thread out for me Shawn. So many threads come
across when you’re gone a week that I usually just mark them as
‘read’.

Anyway, rbgccxml is no longer using hpricot. As libxml-ruby has
matured extensively in the past months, I’ve moved over to that
library. Much faster than hpricot. That said, I will take greater care
in how I define dependencies to hopefully prevent this problem from
happening again.

Further questions about these projects should be posted on the
rubyforge forums page: http://rubyforge.org/forum/?group_id=5393
Posting here will send me an email which will allow me to respond
quicker.

Hope that helps.

Jason

-------- Original-Nachricht --------

Datum: Tue, 19 Aug 2008 00:52:19 +0900
Von: “Jason R.” [email protected]
An: [email protected]
Betreff: Re: rbgccxml / rbplusplus gem dependency on hpricot question

contact him after that, and I’m sure he’ll give you a speedy response.

Hope that helps.

Jason

Dear Jason,

thanks for your response and for your work.
However, I still get this error:

[email protected]:~/Desktop$ sudo gem install rbplusplus
ERROR: Error installing rbplusplus:
rbgccxml requires hpricot (= 0.6, runtime)

What should I do ?

Thank you,

Axel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs