rbenv: ruby: command not found The `ruby' command exists in these Ruby versions: 2.5.1

I installed ruby 2.5.1 and rail 5.2.1 on CentOS7 . I have an existing rail project which is 3.2.13. Now the existing rail project does not run in my local environment.
I create a new project on rail and it runs

[[email protected] html]# cd ruby_rails/

[[email protected] ruby_rails]# bin/rails server

=> Booting Puma

=> Rails 5.2.1 application starting in development

=> Run rails server -h for more startup options

Puma starting in single mode…

  • Version 3.12.0 (ruby 2.5.1-p57), codename: Llamas in Pajamas

  • Min threads: 5, max threads: 5

  • Environment: development

  • Listening on tcp://0.0.0.0:3000

Use Ctrl-C to stop

Started GET "/" for 127.0.0.1 at 2018-10-06 21:43:25 +0900

Processing by Rails::WelcomeController#index as HTML

Rendering /root/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/templates/rails/welcome/index.html.erb

Rendered /root/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/templates/rails/welcome/index.html.erb (11.4ms)

Completed 200 OK in 188ms (Views: 131.5ms | ActiveRecord: 0.0ms)

But I have an existing project on rails 3.2.13 that does not run on my local environment

[[email protected] html]# cd rehome_navi-master/

[[email protected] rehome_navi-master]# bin/rails server

rbenv: ruby: command not found

The `ruby’ command exists in these Ruby versions:

2.5.1

I really need to run this project. please help me.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs