I’ve been using Ruby 2.0.0 since 2013, and am finally being pushed to upgrade to a newer version for my Rails apps. I determined that I need to upgrade to at least 2.5.7. So, using rbenv to support multiple Ruby versions (been using that since then as well), I installed 2.5.7. But ever since doing that, my Rails app won’t run in 2.0.0, giving the following error: /Users/jackrg/.rbenv/versions/2.0.0-p576/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require’: dlopen(/Users/jackrg/.rbenv/versions/2.0.0-p576/lib/ruby/2.0.0/x86_64-darwin15.0.0/digest/sha1.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib (LoadError)
I did observe that the first thing the installation for 2.5.7 did was to install OpenSSL 1-1.1. So it seems like I have a problem where multiple versions of SSL are required. Is there a way around this issue?