Rb_sys_fail(socket(2)) Ticket #9438


#1

Where are we with respect to the (Windows) one click installer & this
issue?

I don’t have VC++ 8 & so can’t compile. Are there binaries available
somewhere? If so can I just plop 'em in \ruby\bin? Should I fall back to
1.8.4?
-SHAWN-


#2

Shawn F. wrote:

Where are we with respect to the (Windows) one click installer & this
issue?

I don’t have VC++ 8 & so can’t compile. Are there binaries available
somewhere? If so can I just plop 'em in \ruby\bin? Should I fall back to
1.8.4?
-SHAWN-

You could try the mingw ruby version. Then at least you have the
compiler.
Should it fail there then…unfortunately you’ll probably have to hack
around in the C and try and figure out what is going on.
It might be a ruby bug, might be a VC6 bug.
you could try cygwin, too.
Also could file a bug report on http://redmine.ruby-lang.org/
Cheers!
-=R


#3

“Roger P.” removed_email_address@domain.invalid wrote in message
news:removed_email_address@domain.invalid…

compiler.
Should it fail there then…unfortunately you’ll probably have to hack
around in the C and try and figure out what is going on.
It might be a ruby bug, might be a VC6 bug.
you could try cygwin, too.
Also could file a bug report on http://redmine.ruby-lang.org/
Cheers!
-=R

Yes in fact it was determined (more or less) to be a … call it a VC6
RT
incompatibility. At any rate, dev folks are aware of it. In fact the
ticket
was closed almost a year ago. The binaries installed by the one click
installer still suffer the problem (as of 1.8.6-26, PL 111).

I was hoping somebody had devised a workaround or there was a VC8 binary
set
around somewhere. I’m planning on distributing a rubyscript2exe
executable
that will target XP & use ICMP. But… that part is mostly just a
whistle. I
could do without it. Or 1.8.4 is an option.

Anyway thanks for the reply.
-SHAWN-


#4

http://www.akitaonrails.com/2008/7/26/still-playing-with-ruby-on-windows
is an example of the mingw installer. Perhaps it plays better.
Cheers!
-=R

Rats! No joy there either. Still - cool tips :slight_smile:
I’ll probably either fall back or just forget about ICMP. Es no biggie.

Thanks for your help R.
-SHAWN-


#5

Rats! No joy there either. Still - cool tips :slight_smile:
I’ll probably either fall back or just forget about ICMP. Es no biggie.

Heh. If it’s an msvcrt6 thing then you’ll either need to find [create?]
a work around using msvcrt6 [maybe ask the mingw guys?] or build your
own that doesn’t use msvcrt6–i.e. recompile all of ruby using a newer
MS VC compiler than 6.0–scary.
Take care!
-=R


#6

Shawn F. wrote:

“Roger P.” removed_email_address@domain.invalid wrote in message
news:removed_email_address@domain.invalid…

compiler.
Should it fail there then…unfortunately you’ll probably have to hack
around in the C and try and figure out what is going on.
It might be a ruby bug, might be a VC6 bug.
you could try cygwin, too.
Also could file a bug report on http://redmine.ruby-lang.org/
Cheers!
-=R

Yes in fact it was determined (more or less) to be a … call it a VC6
RT
incompatibility. At any rate, dev folks are aware of it. In fact the
ticket
was closed almost a year ago. The binaries installed by the one click
installer still suffer the problem (as of 1.8.6-26, PL 111).

I was hoping somebody had devised a workaround or there was a VC8 binary
set
around somewhere. I’m planning on distributing a rubyscript2exe
executable
that will target XP & use ICMP. But… that part is mostly just a
whistle. I
could do without it. Or 1.8.4 is an option.

Anyway thanks for the reply.
-SHAWN-

If it’s a VC6 bug then it might not be a super huge prio, since OCI is
moving away from VC6 hopefuly soon.

http://www.akitaonrails.com/2008/7/26/still-playing-with-ruby-on-windows
is an example of the mingw installer. Perhaps it plays better.
Cheers!
-=R


#7

2008/10/31 Shawn F. removed_email_address@domain.invalid:

Where are we with respect to the (Windows) one click installer & this issue?

I don’t have VC++ 8 & so can’t compile. Are there binaries available
somewhere? If so can I just plop 'em in \ruby\bin? Should I fall back to
1.8.4?
-SHAWN-

That error was reported and fixed in the latest CVS.

Refer to http://redmine.ruby-lang.org/issues/show/714

Soon or later there will be new release on
http://www.garbagecollect.jp/ruby/mswin32/en/download/release.html

Regards,

Park H.


#8

Heh. If it’s an msvcrt6 thing then …

I decided to just let it go. I’ll come back to it after everything else
is
done.
-SHAWN-


#9

Soon or later there will be new release on

Cool - thanks.
-SHAWN-