Rate of uhd_source

Hi everybody,

I try to use the function uhd.usrp_source.

It works well with the default rate

  •    parser.add_option("-s", "--samp-rate", type="eng_float",
    

default=1e6,
help=“set sample rate (bandwidth)
[default=%default]”)*

But i would like to have a better rate (1e9), and if i change that, it
didn’t works.
Someone know why?

Thank you a lot!

    self.u = uhd.usrp_source(device_addr=options.args,
                             stream_args=uhd.stream_args('fc32'))

    # Set the subdevice spec
    if(options.spec):
        self.u.set_subdev_spec(options.spec, 0)

    self.u.set_samp_rate(options.samp_rate)

On Mon, 7 May 2012 10:50:18 -0300, Loic D. wrote:

Hi
everybody,

I try to use the function uhd.usrp_source.

It
works well with the default rate

parser.add_option("-s",
“–samp-rate”, type=“eng_float”, default=1e6,
help=“set sample rate
(bandwidth) [default=%default]”)

But i would like to have a better
rate (1e9), and if i change that, it didn’t works.
Someone know why?

Thank you a lot!

self.u =
uhd.usrp_source(device_addr=options.args,

stream_args=uhd.stream_args(‘fc32’))

Set the subdevice spec

if(options.spec):

self.u.set_subdev_spec(options.spec, 0)

self.u.set_samp_rate(options.samp_rate)

Requested sample rates from UHD
hardware must be proper divisors of the master sampling rate on the
hardware. For USRP1/B100/E100, that’s 64Msps, and for N2XX it’s 100Msps.

Typically, sample rates between master_rate/4 to master_rate/512 are
supported.

A sample rate of 1e9 is not a valid sample rate–and
seriously 1 Gigasample/second? You really expected your computer to keep
up to 1 GigaSample/second?