Random RoutingError


#1

Hi,
I’m getting “Page Cannot be Found” error. The funny (let’s call it funny
:slight_smile: ) is that is random.
When I restart the server, I can log in into my web properly.
After a few minutes and server “log in’s”, it shows “Page Cannot be
found”

I checked the production.log, and it complains about
ActionController::RoutingError:

How can i debug this error? Why is it random?
Also, it surprise me, that the log says:
Processing Base#index” (instead of the name of the controller,
AuthenticatorController)
ActionController::RoutingError (Recognition failed for
“/authenticator/auth/”):

thanks,

Jean

Here the logs:

Processing Base#index (for 1.2.3.4 at 2007-01-18 01:27:19) [GET]
Session ID: 09f4870ca3e2b381646f00acee7c8c36
Parameters:
{“pwd”=>“a1ff1ead1ba7c17257687763772f2af69b753d16ce19b681fa0b232a2ec1bc43f79658b520e025fa2da137d768aa1b77bbf2a64529500e191dd7c2ac5dd44b5d6cad64e309132da29735562e1bcb626fae3c20448ae82c1121ba9afefed11fcf4c54b957a275596d221dd28d8f7d2608096f8cab7fd4f1089eb5283be0a5dd9b”,
“usr”=>“usert@testingcom”}

ActionController::RoutingError (Recognition failed for
“/authenticator/auth/”):

/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/routing.rb:522:in
`recognition_failed’

/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/routing.rb:512:in
`recognize!’

/usr/local/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:38:in
`dispatch’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/rails.rb:73:in
`process’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:551:in
`process_client’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:550:in
`process_client’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:636:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:636:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:625:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:956:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:955:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:127:in
`run’

/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/command.rb:199:in
`run’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
/usr/local/bin/mongrel_rails:18


#2

Hi,
just some other details of this annoying bug … I can replicate it by
calling very often this url in the browser (in my local machine):

www.mytestingweb.com/authenticator/auth/?usr=removed_email_address@domain.invalid&pwd=c253cb050f104af4af6b

This URL will invoke the auth method in the authenticator class.
It seems that when this is run repeatedly and often, it gets somehow to
a collision or something than crash, giving the RoutingError.
Mmmm is there any problem with mongrels when calling very often?
collision? Mongrels have been working fine for me for this time … I
don’t think that all of a sudden, there are collision problems.

any comment will be much appreciated,

regards,

Jean