Rakismet revisited :(


#1

Hey all,

Ok it seems that I got my one app upgraded to 2.1.2 successfully. Yeah!
Now, when I try to install the Rakismet plugin I get the following:

script/plugin install git://github.com/jfrench/rakismet
script/plugin install git://github.com/jfrench/rakismet
removing: C:/DEVELOPMENT/osc/vendor/plugins/rakismet/.git

Basically the plugin is not installed at all :frowning: Seems that something is
wrong here, not sure what I am doing wrong. Also, on a slightly
different subject, what would be the better option

  1. Continue trying until I get Rakismet working or,
  2. Rather use the Plugin and method of Railscast here:
    http://railscasts.com/episodes/65

Thanks again to everyone for your assistance,
Schalk


#2

Schalk,

The install worked fine in this environment:

Ruby version 1.8.7 (powerpc-darwin9)
RubyGems version 1.3.1
Rails version 2.1.2
Active Record version 2.1.2
Action Pack version 2.1.2
Active Resource version 2.1.2
Action Mailer version 2.1.2
Active Support version 2.1.2
Application root /Users/rick/test212
Environment development
Database adapter sqlite3
Database schema version 0

I’m assuming that C:/DEVELOPMENT/osc is the root of your rails
application. You might try adding the -v option to plugin to see if
you can get more information on what’s happening.

Rick


#3

Hey Rick,

Adding -v generates the following output:

script/plugin -v install git://github.com/jfrench/rakismet
Plugins will be installed using http
git clone --depth 1 git://github.com/jfrench/rakismet
“C:/DEVELOPMENT/osc/vendor/plugins/rakismet”
removing: C:/DEVELOPMENT/osc/vendor/plugins/rakismet/.git

Thanks,
Schalk


#4

There’s an obvious question: do you have git installed ? What happens
if you just run
git
from the command prompt ?

Fred


#5

hehehehe, no I don’t.


#6

Hi again Schalk,

I’m assuming from the command output that you didn’t succeed in
installing the plugin because here’s what I see on my machine:

script/plugin -v install git://github.com/jfrench/rakismet
Plugins will be installed using http
git clone --depth 1 git://github.com/jfrench/rakismet “/Users/rick/
test212/vendor/plugins/rakismet”
removing: /Users/rick/test212/vendor/plugins/rakismet/.git
Initialized empty Git repository in /Users/rick/test212/vendor/plugins/
rakismet/.git/
remote: Counting objects: 45, done.
remote: Compressing objects: 100% (34/34), done.
remote: Total 45 (delta 13), reused 43 (delta 11)
Receiving objects: 100% (45/45), 10.78 KiB, done.
Resolving deltas: 100% (13/13), done.

And I get these results consistently with rails 2.1.1, 2.1.2, 2.2.0,
and 2.2.2. So I’m thinking the problem isn’t with the jfrench site.
You can confirm this by trying to grab a different plugin, say
will_paginate with

script/plugin install git://github.com/mislav/will_paginate.git

Bet that didn’t work either, did it?

So I’m not sure what your problem is here but here’s what I’d try.

Lets see if you can create anything in vendor/plugins. Cd to vendor/
plugins and run “git init”. Do you now have a .git directory?
If not, your problem is directory access. Check ownership and
permissions. Is it possible you might have run “rails osd” as user1
and now you’re user2?

Lets see if you can install either gem in a brand new project. So
start from “rails newname”. Cd into newname/ and issue the script/
plugin command. Anything different here?

Rick

On Nov 23, 10:41 am, Schalk N. removed_email_address@domain.invalid


#7

Ok, I now installed git using:

gem install git-rails

Successfully installed fattr-1.0.3
Successfully installed arrayfields-4.6.0
Successfully installed main-2.8.3
Successfully installed git-rails-0.2.1
Successfully installed rubyforge-1.0.1
5 gems installed
Installing ri documentation for git-rails-0.2.1…
Installing ri documentation for rubyforge-1.0.1…
Installing RDoc documentation for git-rails-0.2.1…
Installing RDoc documentation for rubyforge-1.0.1…

gem list confirms that it is installed. Tried Rakismet again:

script/plugin install git://github.com/jfrench/rakismet

No output, no error, no installation. Is there something one needs to do
after installing the git plugin?

Thanks,
Schalk


#8

On 24 Nov 2008, at 11:07, Schalk N. wrote:

5 gems installed
to do
after installing the git plugin?

Don’t know what git-rails is but it’s much more likely to be tools
for working with git than git itself.
If you can’t run

git

from the command line then you’re not ready.

Fred


#9

Ok, I see. I have to install Git itself as well as the rails plugin
alone will not do the trick. Doing that now.


#10

Hi Frederick,

Installed GIT, opened the git bash and executed:

git init

inside the vendor/plugins directory. This successfully created a .git
folder with some folders inside.

Thanks,
Schalk


#11

Schalk,

Git on Windows is a different beast, try googling for it…

Cheers, Sazima