"rake test" works but "rake test:units" fails


#1

“rake test” runs all the tests as it should…

but “rake test:units”
C:…>rake test:units
(in C:/…/…)
rake aborted!
FATAL C3D000 Mdatabase “postgres” does not exist Fpostinit.c
L274
RInitPostgres

(See full trace by running task with --trace)

Small part of the trace:
C:…>rake test:units --trace
(in C:/…/…)
** Invoke test:units (first_time)
** Invoke db:test:prepare (first_time)
** Invoke db:abort_if_pending_migrations (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:abort_if_pending_migrations
** Execute db:test:prepare
** Invoke db:test:load (first_time)
** Invoke db:test:purge (first_time)
** Invoke environment
** Execute db:test:purge
rake aborted!
FATAL C3D000 Mdatabase “postgres” does not exist Fpostinit.c
L274 RInitPostgres
C:/Ruby/lib/ruby/gems/1.8/gems/postgres-pr-0.5.0/lib/postgres-pr/connection.rb:81:in
initialize' C:/Ruby/lib/ruby/gems/1.8/gems/postgres-pr-0.5.0/lib/postgres-pr/connection.rb:55:inloop’
C:/Ruby/lib/ruby/gems/1.8/gems/postgres-pr-0.5.0/lib/postgres-pr/connection.rb:55:in
initialize' C:/Ruby/lib/ruby/gems/1.8/gems/postgres-pr-0.5.0/lib/postgres-pr/postgres-compat.rb:23:innew’
C:/Ruby/lib/ruby/gems/1.8/gems/postgres-pr-0.5.0/lib/postgres-pr/postgres-compat.rb:23:in
`initialize’

Note that test:functionals, and test:integration produce the same
result.
test, development, production databases all work fine. Is there a way
that test:units is somehow using different configuration settings? Where
do I look?

I’m using rails 2.2.2

Thanks