Rake Routes Blank on upgrade to Rails 3

I have just upgraded an app to rails 3 following the railscast
screencast. I have installed a blank application inside the app to be
upgraded with:

rails new .

I have replaced all the the main files.

When I run rake routes I get no output.

routes.rb:

App::Application.routes.draw do
resources :products
end

(ie, just the default file with an example uncommented)

I have tried a number of ways to try and get the routes to be
recognised with no luck.
In the console

puts App::Application.routes.route

gives:

   /assets                                  {}
   /rails/info/properties(.:format)         {:controller=>"rails/

info", :action=>“properties”}

http://localhost:3000/rails/info/properties

gives the error:

Unknown action
The action ‘properties’ could not be found for Rails::InfoController

When I click “About your applications environment” on the index.html
page I get:

LoadError in Rails::InfoController#properties

I’m not sure if these bugs are related, but About your applications
environment works fine with the same gemset on a new application.

Any ideas on how to investigate this and get my routes recognised
would be most helpful,

Many thanks,

Mike

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs