Rake remote:setup - rake aborted! fingerprint b7:df:i8... do

I have become a bit frustrated with trying to deploy my application,
every time I try to deploy using rake remote:setup I get this error
message:

rake aborted!
fingerprint b7:df:i8… does not match for mydomain.com

I am using net-ssh 1.1.1

Any help/insight would be greatly appreciated.

Thank You

Anybody else have this problem?

can you ssh to the server with the same user no problem?

I was having a similar problem and posted about it at
http://www.ruby-forum.com/topic/110933

Check your .ssh/known_hosts file and see if the server you’re trying to
connect to is in there, you might need to delete it.

Yup I ran this on my Mac:

unset SSH_AUTH_SOCK

… and then ran the rake remote:deploy command and it worked like a
charm!!!

Thank you! Thank you! Thank you! On to the next issue :slight_smile:

On Jun 8, 9:38 am, Ivan S. [email protected]

I spoke too soon. I was able to run “rake remote:deploy” and it asked
for my password so it was able to connect. However if I try to run
“rake remote:setup” I still get the fingerprint error. I am deploying
from my Mac PowerBook to a Linux test server. Frustrating. Thanks.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs