Rake rails:freeze:gems failing

I’m new to rails so pre-apologies if this is stupid…

I’m trying to deploy my first app. I need to freeze, but when i run
rake rails:freeze:gems the rake aborts. I also tried
rails:freeze:edge. No idea what to do now. Any help would be
appreciated.

$ rake --trace rails:freeze:edge TAG=rel_1-2-6
(in /Users/Dan/sites/client-inertia/artfeed)
rake aborted!
no such file to load – /Users/Dan/sites/client-inertia/artfeed/
config/…/vendor/rails/railties/lib/initializer
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/rubygems/custom_require.rb:27:in gem_original_require' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 1.8/rubygems/custom_require.rb:27:inrequire’
/Users/Dan/sites/client-inertia/artfeed/config/boot.rb:7
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/rubygems/custom_require.rb:27:in gem_original_require' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 1.8/rubygems/custom_require.rb:27:inrequire’
/Users/Dan/sites/client-inertia/artfeed/rakefile:4
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:2149:in load' /Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:2149:inraw_load_rakefile’
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1897:in
load_rakefile' /Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:instandard_exception_handling’
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1896:in
load_rakefile' /Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1880:inrun’
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in
standard_exception_handling' /Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1878:inrun’
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/bin/rake:31
/usr/bin/rake:19:in `load’
/usr/bin/rake:19

$ rails --version
Rails 1.2.6

$ gem --version
1.0.1

$ ruby --version
ruby 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]

I had the same problem,
For what ever reason, you have a directory named “rails” in your
vendor directory. Mine was empty, but the config\boot.rb looks for it
and decides whether to do a VendorBoot or a GemBoot based on
File.exist?("#{RAILS_ROOT}/vendor/rails")

I deleted the empty rails directory and the empty vendor directory and
everthing worked
I think this is bug in Rails, at least it is not roubust.

Part of config\boot.rb

def pick_boot
  (vendor_rails? ? VendorBoot : GemBoot).new
end

def vendor_rails?
  File.exist?("#{RAILS_ROOT}/vendor/rails")
end

do
rake rails:freeze:edge TAG=rel_1-2-3

or
rake rails:freeze:edge TAG=rel_1-2-6 etc

good luck

and no, it wasn’t at all stupid on your part. Rails is a little stupid
here. Took me an hour to figure it out.

TW Scannell aka RubyFreak

ruby freak… thanks! i ended up just trashing my local copy and re-
checking it out from svn, and it worked. i imagine this had the same
effect as your fix (if those directories were created at some point
after my prior checkout). but thanks because this will be very helpful
for future reference.

I made a typo
I said"
I deleted the empty rails directory and the empty VENDOR directory and
everything worked

what I should have said was
I deleted the empty rails directory and the empty PLUGINS directory in
the vendor directory and
everything worked.

Hope this helps someone.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs