Rake migrate crashes with last trunk

Hello,
I can’t migrate anymore using the last trunk. Here are the messages I
have :

s15222373:/home/www/fredericdevillamil.com/log# rake --trace db:migrate
RAILS_ENV=“production”
(in /home/www/fredericdevillamil.com)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate
** Invoke db:schema:dump (first_time)
** Invoke environment
** Execute db:schema:dump
rake aborted!
undefined method each' for #<Mysql:0x2ad0db90d860> /home/www/fredericdevillamil.com/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:270:intables’
/home/www/fredericdevillamil.com/config/…/vendor/rails/activerecord/lib/active_record/schema_dumper.rb:51:in
tables' /home/www/fredericdevillamil.com/config/../vendor/rails/activerecord/lib/active_record/schema_dumper.rb:20:indump’
/home/www/fredericdevillamil.com/config/…/vendor/rails/activerecord/lib/active_record/schema_dumper.rb:14:in
dump' /home/www/fredericdevillamil.com/config/../vendor/rails/railties/lib/tasks/databases.rake:24 /home/www/fredericdevillamil.com/config/../vendor/rails/railties/lib/tasks/databases.rake:23 /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in execute' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:ininvoke’
/usr/lib/ruby/1.8/thread.rb:135:in synchronize' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:ininvoke’
/home/www/fredericdevillamil.com/config/…/vendor/rails/railties/lib/tasks/databases.rake:5
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in execute' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:in invoke' /usr/lib/ruby/1.8/thread.rb:135:insynchronize’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
/usr/bin/rake:18

Cheers
Frederic

Frédéric de Villamil
“Quand tu veux chasser une belle fille, il vaut mieux commencer par
draguer sa copine moche” – précepte de go.
http://t37.net http://fredericdevillamil.com
[email protected] tel: +33 (0)6 62 19 1337

Frederic de Villamil a écrit :

** Invoke db:schema:dump (first_time)
/home/www/fredericdevillamil.com/config/…/vendor/rails/activerecord/lib/active_record/schema_dumper.rb:14:in
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in execute' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:ininvoke’
/usr/lib/ruby/1.8/thread.rb:135:in synchronize' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:ininvoke’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in run' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
/usr/bin/rake:18

Cheers
Frederic

Sorry for bothering you, was my rails install that was fucked up.


Frédéric de Villamil
“Quand tu veux chasser une belle fille, il vaut mieux commencer par
draguer sa copine moche” – précepte de go.
http://t37.net http://fredericdevillamil.com
[email protected] tel: +33 (0)6 62 19 1337

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs