Rake error

I posted this on Ruby T. but then I realized I probably should of
posted it here instead…

I receive this error when running a rake command:

$ rake db:migrate
(in /Users/jeremy/rails/depot)
dyld: NSLinkModule() error
dyld: Library not loaded: /usr/local/mysql/lib/mysql/libmysqlclient.
15.dylib
Referenced from: /usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/lib/
mysql.bundle
Reason: image not found
Trace/BPT trap

I’m working with the book “Agile Web D. with Rails” and even
though it discusses many possible errors, none of them relate to this
one. Also, my database.yml file seems to be correct so I don’t think
that’s the problem.

On May 26, 9:16 pm, Jeremy H. [email protected] wrote:

Referenced from: /usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/lib/
mysql.bundle
Reason: image not found
Trace/BPT trap

I’m working with the book “Agile Web D. with Rails” and even
though it discusses many possible errors, none of them relate to this
one. Also, my database.yml file seems to be correct so I don’t think
that’s the problem.

Well I discovered the diagnoses but not the cure. My “libmysqlclient.
15.dylib” file is located in “/usr/local/mysql/lib” instead of “/usr/
local/mysql/lib/mysql”. I opened up the “mysql.bundle” file in vi but
it was complete chaos. I could see where to make the change but it
didn’t look safe to edit the file. What do I do?

On May 26, 2007, at 11:36 PM, Jeremy H. wrote:

dyld: Library not loaded: /usr/local/mysql/lib/mysql/libmysqlclient.

To post to this group, send email to [email protected]
To unsubscribe from this group, send email to rubyonrails-talk-
[email protected]
For more options, visit this group at http://groups.google.com/
group/rubyonrails-talk?hl=en
-~----------~----~----~----~------~----~------~–~—

I found the answer on Google.
http://railsforum.com/viewtopic.php?pid=24070

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs