Rake error - please help

Hi-

I’m suddenly getting this rake error where as before I wasn’t. And
nothing’s been changed. As you can see it says something about
“load_missing_constant”. Is my development environment broken? Can
someone please tell me what this error means?:

[email protected]:~/RailsProjects/rails_space$ rake test:functionals
(in /home/bbgun/RailsProjects/rails_space)
/usr/local/bin/ruby -Ilib:test
“/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb”
“test/functional/user_controller_test.rb”
“test/functional/community_controller_test.rb”
“test/functional/faq_controller_test.rb”
“test/functional/spec_controller_test.rb”
“test/functional/profile_controller_test.rb”
“test/functional/site_controller_test.rb”
/home/bbgun/RailsProjects/rails_space/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:266:in
load_missing_constant': uninitialized constant ApplicationController (NameError) from /home/bbgun/RailsProjects/rails_space/config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:452:inconst_missing’
from
/home/bbgun/RailsProjects/rails_space/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:464:in
const_missing' from /home/bbgun/RailsProjects/rails_space/config/../app/controllers/application.rb:3 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from /home/bbgun/RailsProjects/rails_space/config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:495:inrequire’
from
/home/bbgun/RailsProjects/rails_space/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:342:in
new_constants_in' from /home/bbgun/RailsProjects/rails_space/config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:495:inrequire’
… 12 levels…
from
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5:in
load' from /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5 from /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5:ineach’
from
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/usr/local/bin/ruby -Ilib:test
"/usr/local…]

(See full trace by running task with --trace)
[email protected]:~/RailsProjects/rails_space$

Hi,

On Dec 5, 2007 1:04 PM, Brian B. [email protected]
wrote:

Hi-

I’m suddenly getting this rake error where as before I wasn’t. And
nothing’s been changed. As you can see it says something about
“load_missing_constant”. Is my development environment broken? Can
someone please tell me what this error means?:

It looks like your ApplicationController class might be missing. This
file
should be located in RAILS_ROOT/app/controller/application.rb

Does this file exist? Something in that file may point you in the right
direction.

“test/functional/profile_controller_test.rb”

`require’
/home/bbgun/RailsProjects/rails_space/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:495:in
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3
[email protected]:~/RailsProjects/rails_space$

Posted via http://www.ruby-forum.com/.

HTH,
Michael G.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs