Rake db:create:wants LibMySQL.dll for MySQL 5.0.37; where?

Hi All,

I’m running:
WinXP-Pro/SP3
Rails 2.3.5
MySQL 5.0.37-community-nt

I ran rake db:create:all and got something like:
LibMySQL.dll required.

I had a worse symptom previously when, on an earlier post on a related
failure, Sharagoz kindly suggested I drop back to a 5.0 version of
MySQL.

As I prepared this post, I wanted to recall my version. In
particular, I wanted to run
select * version() in MySQL. But I was told Windows didn’t have that
app. So I added a path to it in the environment. ( thought I
requested this during installation.)

When I ran the rake command this time, the problem disappeared.

I just posted this to encourage other people who, like me, sometimes
get discouraged with all the problems that software development gives
us. We just need to keep on plugging and help others when we can.

Best wishes,
Richard

When you download the DLL file, you need the key of the file and you can get the key for download Libmysql.dll and get more than information about this file.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs