Rake db:migrate sucks

I have installed ruby1.8.5-22 under windows,
and then rails 1.2.3
and also i update rubygems to 0.9.3 with gems update --system
however,when i enter the project directory and input the command rake
db:migrate,it sucks with the following errors:

rake aborted!
uninitialized constant ActionController
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:2028:in
const_missing' D:/RubyForge/gmaps/config/../app/controllers/application.rb:4 c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_re
quire’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' D:/RubyForge/gmaps/config/../lib/tasks/importing_tasks.rake:36 c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:7:inload’
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:7
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:7:in
each' c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/rails.rb:7 c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_re
quire’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' D:/RubyForge/gmaps/rakefile:10 c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:inload’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in
raw_load_rakefile ' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1727:inload_rakefile’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
standard_exceptio n_handling' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1726:inload_rakefile’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1710:in run' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:instandard_exceptio
n_handling’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in run' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7 c:/ruby/bin/rake.bat:20:inload’
c:/ruby/bin/rake.bat:20

anybody who can help me with that?

fred wrote:

anybody who can help me with that?

Hi Fred,

rake db:migrate works for everyone who has setup their system correctly.

You don’t mention what database you are using, or how you have
configured it.

rgds,

  • matt.

Hilarious title, kudos.

Hi Fred,

rake db:migrate works for everyone who has setup their system correctly.

You don’t mention what database you are using, or how you have
configured it.

you can also get more info by adding rake --trace ; it gives more
verbose info.
aside from that, what migration are you trying to do? do you have a
shcema.rb file in the db directory? a 001_add_table.rb or
002_migration_file.rb in db/migrate/* ?

Yeah… what’s this:

D:/RubyForge/gmaps/config/…/app/controllers/application.rb:4

b

At first glance, it looks like there’s something wrong with your
environment setting, particularly the path.

and input the command rake

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs