Rake db:migrate failing

I’m running/developing some sites on Rails 2.0.2 and some on 1.2.6. I
updated to 2.0.2 last night and, while the 1.2.6 sites (using engines)
seem to run perfectly (after replacing ‘require_gem’ with ‘gem’ - which
seems wrong), I’m getting this:

mac-san:~/dev/russell_store wiseleyb$ rake db:migrate --trace

I did a script/generate plugin_migration - and that worked fine. But I
the error above when I do rake db:migrate. rake db:migrate works fine
the 2.0.2 sites (that aren’t using engines yet).

Any ideas what would be causing this? I grabbed the latest engines

script/plugin install http://svn.rails-engines.org/plugins/engines

I’m running this project on RAILS_GEM_VERSION = ‘1.2.6’

Here is the relevant gem list:

rails (2.0.2, 1.2.6,, 1.2.3, 1.2.1, 1.1.6)
rake (0.8.0, 0.7.3, 0.7.1)
rubygems-update (1.0.1)
actionmailer (2.0.2, 1.3.6,, 1.3.3, 1.3.1, 1.2.5)
actionpack (2.0.2, 1.13.6,, 1.13.5, 1.13.3, 1.13.1, 1.12.5)
actionwebservice (1.2.6, 1.2.5, 1.2.3, 1.2.1, 1.1.6)
activerecord (2.0.2, 1.15.6,, 1.15.5, 1.15.3, 1.15.1, 1.14.4)
activeresource (2.0.2,
activesupport (2.0.2,, 1.4.4, 1.4.2, 1.4.0, 1.3.1)

On clue might be that when I first did a “script/server” on this
after updating it failed on “require_gem” - which is deprecated in Rails
2.0.2 but, given RAILS_GEM_VERSION = ‘1.2.6’ - shouldn’t that still be
kosher? It seems like some things are running on Rails 2.0.2 instead of
version specified.

Sorry for the long email - I’ve kind of hit a wall on this and it seems
engines related.


HI Ben,

Looks like this could be a bad interaction between Rake 0.8 and one of
the hoops that the engines plugin needed to jump through to redefine
the plugin doc rake task. I’ll see if anything can done - in the
meantime, just comment out the appropriate task and the
“redefine_task” method in the engines plugin’s engines.rake file



I updated from http://svn.rails-engines.org/engines/trunk/ but that
seem to help.

Got a

mac-san:~/dev/russell_store wiseleyb$ rake db:migrate --trace

gem_original_require' /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’

I grabbed this http://svn.rails-engines.org/plugins/engines/ and renamed
engines/tasks/engines.rake to engines.rake.old and migrations ran.

Thanks for trying though! Let me know if you want me to try anything
locally to help debug this.


I’ve committed a fix to trunk - let us know how that fares.


Hi Ben,

Am 23.12.2007 um 16:50 schrieb ben wiseley:

uninitialized constant Rails::Plugin

The Rails::Plugin class is part of Rails 2.0.x. So this seems to
indicate that Rails 1.2.6 gets loaded.

I’m running this project on RAILS_GEM_VERSION = ‘1.2.6’

Have you tried to change this to 2.0?

sven fuchs [email protected]
artweb design http://www.artweb-design.de
grünberger 65 + 49 (0) 30 - 47 98 69 96 (phone)
d-10245 berlin + 49 (0) 171 - 35 20 38 4 (mobile)

No - because this is a 1.2.6 project - it’s not even close to ready for
I thought I made that clear before but, since it’s trunk, I should have
known it was the 2’ish code… duh, stupid me (it’s been a long month)
I was having problems running 1.2.6 projects after I updated to Rails
2.0and Gems
1.0 - that was the original question. 1.2.6 projects (with engines)
ran, my 2.0 projects ran, rake db:migrate just failed on 1.2.6 projects.


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs