Rake db:migrate and mysql


#1

Hi, when I run this it aborts with an access denied message and
usepassword = NO

How do I change this to either not require a password, or allow me to
set the password in the rake command line execution (it’s set in the
database.yml file, but rake isn’t using it)


#2

I’m not sure about setting the password at the execution, but I would
double check the password in the yml file first. Also check with your
database and make sure the username/password combination you’re using
matches the database’s. Seems simple but its happened to me before.


#3

jthompson wrote:

I’m not sure about setting the password at the execution, but I would
double check the password in the yml file first. Also check with your
database and make sure the username/password combination you’re using
matches the database’s. Seems simple but its happened to me before.

Thanks for the reply. I had typoed the word password parameter in the
.yml file