Rake appdoc errors


#1

when running rake rake appdoc (os x 10.4) i get the following error:

unrecognized option `–line-numbers --inline-source’

any ideas?

sebastian


#2

On Mon, 2006-02-27 at 21:13 -0600, Sebastian F. wrote:

when running rake rake appdoc (os x 10.4) i get the following error:

unrecognized option `–line-numbers --inline-source’

any ideas?


yep - pulled my hair out on this a few days ago…

http://dev.rubyonrails.org/ticket/3757

from what I saw, there are 3 instances in documentation.rake that had to
be fixed (at least on my system).

so when I ran patch…it only fixed the first one and it took me a few
WTF moments to figure out that there were actually 2 more instances that
didn’t get patched.

Craig


#3

How did you fix those?


#4

assuming that you don’t understand patch…see this…

http://dev.rubyonrails.org/changeset/3649

this is the change that you need to make to fix it.

what is currently in your documentation.rake is in red
what you need to make those lines look like is in green

Craig


#5

On 2/28/06, Sebastian F. removed_email_address@domain.invalid wrote:

How did you fix those?

On my system - a Mac OS X with ruby 1.8.4 installed from
sources and gem - I had to fix this files:

/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.11.2/rakefile
/usr/local/lib/ruby/gems/1.8/gems/actionwebservice-1.0.0/Rakefile
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/rakefile
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/rails_generator/generators/components/plugin/templates/Rakefile
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/tasks/documentation.rake
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/tasks/documentation.rake

The change consists of adding rdoc options using ‘<<’ operator.
So I changed every occourrence of

'rdoc.options << ‘–line-numbers --inline-source …’

with

rdoc.options << ‘–line-numbers’ << ‘–inline-source’ << …

Ciao.
– fabio


#6

Thanks all. Did the edits and finally got it to work. Ouch.

sebastian