RailsXls Plugin Not Working With Rails(2.0.2,2.1.0,2.1.2)


I am using RailsXls Plugin to generate Excel Reports from Query
Results in a Database

I am using the Latest version of RailsXls

I am using Rails 2.1.0.I Have Downloaded the Jdk Version 5.0.The other
dependency Jakarta is supplied with the part of the package itself.So
i didnt download it

I Have placed the RailsXls Plugin in vendor/plugins directory

But whenever i am trying to start the webrick server in my radrails i
get the following error in my console

dependencies.rb:493:in `const_missing’: uninitialized constant
Rails::Plugin::Worksheet (NameError)

where newohum/redmineupdated is the path of my application

I have even tried with Rails 2.0.2,2.1.0,2.1.2 versions of rails.But
the problem remains the same

I have one more folder called rails in my vendor folder in addition to
my plugins folder.

I tried removing the rails folder in My vendor directory because i
have already have three versions of rails in my local syste,.But
removing the Rails folder in plugin directory also makes my webrick
server to start.

Please help me in this issue. Is there any dependency of RailsXls
Plugin with rails version.I Have also tried with parseexcel gem to
create excel reports but thats also not working

Whatever method written in The plugin i am unbale to access it in my
controller since it always gives the error as Undefined method.I Have
even tried with include and require statements with the name of the
plugin.I even tried giving the fullpath of the Plugin directory in My
controller files to access the Plugin functions

Please guide me in This issue