Rails3 + rcov

I hit a wall today with rcov + Rails3.

I am developing my Rails3 app using Ruby 1.9.2-preview3. rcov and
relevance-rcov do not work with Ruby 1.9.2 yet. I can’t find any fork
of rcov that does yet either. It wasn’t that big of a deal since I
could easily switch over to Ruby 1.8.7 using rvm --default 1.8.7; rake
test:coverage.

So then today I brought my app forward from beta4 to Rails 3.0.0-rc.
That version requires linecache19. The problem is linecache19 doesn’t
compile with 1.8.7, only 1.9.2-preview3, it can’t see my vm_core.h
file no matter how I configure it’s --include-* params. That means I
lost my working rcov on my Ruby 1.8.7 setup and I now only have a
barely working rcov with my 1.9.2-preview3 setup, and it creates
terribly wrong coverage stats.

What’s my short-term solution for a working, accurate rcov?


Greg D.
destiney.com | gregdonald.com

Just use CoverMe – Code Coverage for Ruby 1.9
https://github.com/markbates/cover_me

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs