Rails with Apache and FastCGI under Windows and strange erro

Hi,
I’m deploying a rails application under Windows (not my choice) using
Apache 2.0.59 (I’m stuck with Apache 2.0 since the customer wants a
single-signon solution)and FastCGI.

The rails application talks with an MS SQL Server (again, not my choice)
on a different machine.

And now, enter stage left: Strange Errors. Infrequently I get
“Rails Application Errors” when loading a page in a browser in
production mode. Reloading the frame will produce a working output that
looks as expected. Looking at the logfiles, I invariably find the
following:

Errno::ENOENT (No such file or directory):
C:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/cgi_process.rb:185:in
write' C:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.5/lib/action_controller/cgi_process.rb:185:inout’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:38:in
dispatch' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/fcgi_handler.rb:150:inprocess_request’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/fcgi_handler.rb:54:in
process!' C:/ruby/lib/ruby/site_ruby/1.8/fcgi.rb:598:ineach_cgi’
C:/ruby/lib/ruby/site_ruby/1.8/fcgi.rb:595:in each_cgi' C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/fcgi_handler.rb:53:inprocess!’
C:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/fcgi_handler.rb:23:in
`process!’
C:/rails/myapp/public/dispatch.fcgi:24

Does anyone have a clue as to what file or directory was not found?
Btw, I’m not doing any file-related stuff in my application, so this
should be coming directly from the framework.

Regs,
Sven


BAGHUS GmbH
EDV und Internetdienstleistungen

Staffelseestr. 2
81477 München

Tel.: 0 89 / 5 48 01 66 - 0
Fax.: 0 89 / 5 48 01 66 - 99

www.baghus.net, [email protected]
HRB: 144283, USt-IdNr: DE224865405

Junkmail Catcher, do not use: [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs