Rails under windows and mysql make webrick unstable


#1

hi, I have installed ruby and rails under windows(exactly this one:
http://rubyforge.org/frs/download.php/4174/ruby182-15.exe that
includes rubygems)
the thing is that while trying to install the mysql gem, it seemd to
try to build the native extension, so I finally added a compiled
version that I found in http://dema.ruby.com.br/
the problem is that webrick behaves quite unstable while querying to
the database and makes it to close too often. is anyone suffering this
too?
any recomendation?

thanks in advance


#2

I will answer myself. finally I installed cygwin on my machine and
compiled ruby and installed rubygems and rails and now everything
seems to run fine :slight_smile:


#3

What’s wrong with Instant Rails? It comes with all the stuff you need
out of the box and is as easy to get up and running unzip it to your
drive and develop. I use it and it’s simply a dream come true.

No installing, no path munging, nothing, unzip and develop.

http://instantrails.rubyforge.org/wiki/wiki.pl


#4

Frank H. wrote:

What’s wrong with Instant Rails? It comes with all the stuff you need
out of the box and is as easy to get up and running unzip it to your
drive and develop. I use it and it’s simply a dream come true.

No installing, no path munging, nothing, unzip and develop.

[BW] I wish this were true. I’ve spent the last two days trying
unsuccessfully to get a standard installation working on a Win2K box.
On
advice, I gave that up this morning and downloaded and unzipped
InstantRails
and made the changes to the Apache config file per the FAQ. Three hours
later I still can’t get IR to launch.

Still trying.

Bill

On 1/1/06, Borja Martín removed_email_address@domain.invalid wrote:

version that I found in http://dema.ruby.com.br/
the problem is that webrick behaves quite unstable while querying to
the database and makes it to close too often. is anyone suffering this
too?

any recomendation?

thanks in advance


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


#5

I really don’t know what’s going on with your machine. Out of the
14,000 downloads of Instant Rails, you are the second person I am
aware of who has had this problem.

Of course, I realize that won’t make you feel any better.

Anyway, I just posted some things to try on the thread you started on
the Instant rails mailing list. Also, I’m wondering if you have a
second machine you could try it on – just for comparison purposes?

Curt