Rails requires RubyGems >= 1.3.1 (you have 1.1.1) on OSX


#1

Hi, I just installed rails 2.3.2 and after

rails test
cd test
rake db:migrate
mongrel_rails start

I get this:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Rails requires RubyGems >= 1.3.1 (you have 1.1.1). Please gem update --system and try again.

gem -v => 1.3.1

Any ideas for a solution? Is it possible I have more than one
installation of ruby on my machine, with mongrel accessing the other
one? How do I find out and how do I resolve this?

Thank you!!!


#2

On 20 Mar 2009, at 19:48, Andre In la wrote:

Any ideas for a solution? Is it possible I have more than one
installation of ruby on my machine, with mongrel accessing the other
one? How do I find out and how do I resolve this?

That is possible. Look at the output of
which mongrel_rails
which gem
which ruby

Fred


#3

has you tried

sudo gem install rubygems-update
sudo update_rubygems


#4

alberto wrote:

has you tried

sudo gem install rubygems-update
sudo update_rubygems

Yes, I did do that

Also,

which ruby => /usr/local/bin/ruby
which gem => /usr/local/bin/gem
which mongrel_rails => /usr/bin/mongrel_rails

Any ideas?


#5

Andre In la wrote:

alberto wrote:

has you tried

sudo gem install rubygems-update
sudo update_rubygems

Yes, I did do that

Also,

which ruby => /usr/local/bin/ruby
which gem => /usr/local/bin/gem
which mongrel_rails => /usr/bin/mongrel_rails

Any ideas?

Resolved by
sudo rm /usr/bin/mongrel_rails
sudo gem install mongrel

thank you for the suggestions!


#6

On Mar 21, 2:20 am, Andre In la removed_email_address@domain.invalid
wrote:

which ruby => /usr/local/bin/ruby
which gem => /usr/local/bin/gem
which mongrel_rails => /usr/bin/mongrel_rails

What this means is that your ruby and gem commands were from the ruby
installation in /usr/local, which you have kept up to date (hence gem -
v returning 1.3.1) but the mongrel_rails command was part of the ruby
installation that came with OS X and was using the version of gem that
was part of that ruby installation, which happened to be an earlier
version. removing /usr/bin/mongrel_rails was actually unecessary -
installing mongrel will have created a /usr/local/bin/mongrel_rails
which would have taken precedence over the one in /usr/bin.

Fred