Rails / Rack version mismatch

I attempted to install rails, with these error messages:

$ sudo gem install rails
ERROR: Error installing rails:
actionpack requires rack (~> 1.0.0, runtime)

$ sudo gem install rack
Successfully installed rack-1.1.0
1 gem installed

$ sudo gem install rails
ERROR: Error installing rails:
actionpack requires rack (~> 1.0.0, runtime)

Why does gem install a current version of rack which is incompatible
with the current version of rails? Moreover, why doesn’t install of
rails include the proper rack dependency?

On Feb 4, 2010, at 9:28 AM, RonL wrote:

I attempted to install rails, with these error messages:

$ sudo gem install rails
ERROR: Error installing rails:
actionpack requires rack (~> 1.0.0, runtime)

$ sudo gem install rack
Successfully installed rack-1.1.0
1 gem installed

Try installing rack 1.0.1

~> 1.0.0 means “>= 1.0.0” && “< 1.1”

However, 1.1.0 is not “< 1.1”

irb> req=Gem::Requirement.new("~>1.0.0")
=> #<Gem::Requirement:0x641ae0 @requirements=[["~>", #<Gem::Version
“1.0.0”>]], @version=nil>
irb> req.satisfied_by? Gem::Version.new(“1.0.1”)
=> true
irb> req.satisfied_by? Gem::Version.new(“1.1.0”)
=> false

-Rob

Groups “Ruby on Rails: Talk” group.
To post to this group, send email to rubyonrails-
[email protected]
To unsubscribe from this group, send email to [email protected]
.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en
.

Rob B. http://agileconsultingllc.com
[email protected]

Did you get this solved I have similar issue and am stuck

Sean wrote:

Did you get this solved I have similar issue and am stuck

i got past this by installing rake =)
sudo gem install rake

ok for me this meant “manually install rack 1.1.x then install rails
2.3.18 and magically it works now” ai ai

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs