Rails on ruby-1.8.7


#1

Download page(http://rubyonrails.org/download) tells as follows
“We recommend Ruby 1.8.7 for use with Rails.”

Which version of RoR is stable(or available) on ruby-1.8.7?
I want to use rails-2.1.2. but I dont know that is appropriate.

Im going to run redMine 0.8.0 on Ubuntu 8.10.


#2

you can run rails up to the latest version using ruby 1.8.7 without
problems.


#3

the current stable version (for 1.8) is 1.8.7. that’s all you have to
know.

but to answer your question:
of course development is focussing on compatibility with the next
generation of ruby. 1.8.8 is still to come out later this year (even
though 1.9.1 has been released). but it’s not experimental or
anything. 1.8.7 is working fine. with 1.9.1 there are still problems
with some gems.


#4

Thanks for answering!
and please :), one more question.

I looked for ‘1.8.7’ all the time.
I read ‘1.8.7’ is as pre-release(or experimental-release) for ‘1.9’.

and I found this, in CHANGELOG of rails-2.1.2.

  • Ruby 1.9 compatibility. #1689, #10546 [Cheah Chu Yeow, frederico]

Is this the point of the answer?


#5

On Feb 10, 7:59 am, MaD removed_email_address@domain.invalid wrote:

the current stable version (for 1.8) is 1.8.7. that’s all you have to
know.
A lot of people still run 1.8.6 - not so long ago 1.8.7 was a bit
quirky. Earlier versions of rails wouldn’t quite work with 1.8.7 (I
can remember exactly when 1.8.7 compatibility came in, I suspect 2.1).
The note in the changelog about ruby 1.9 is a bit misleading. Ruby 1.9
was a rapidly moving target at the time. At many points in the past
year people have contributed patches that fixed one aspect of
compatibility with 1.9 only for a subsequent change in 1.9 to unveil
other problems.

Fred