DB field names:
If I have a table that references 2 or more separate users from my users
table, is there a recommended naming convention for this situation? In
my case, I have 3 users associated with a record in my projects table:
I could name one of them “user_id”, and then projects.user would work I
guess, but wouldn’t work for the others. Is there a recommendation for
this kind of situation?
Plurality in Classes:
Not in class names as much as in the part where you say belongs_to,
has_many, etc. Say all my table names are plural in the db. do I say:
In other words, do I need to set the right plurality here, or can I just
point to the exact name of the field in the DB? I’m getting lots of
undefined method `vendor_projects’ for ProjectTranslation:Class
And I’m not sure if that’s related or not.