Rails Installer Problem

Hello. Thanks to all who made the rails installer possible.

I’m going through the video tutorial and am stuck at point 7:00 where
we’re adding to github. Everything went smoothly up to that point.

C:\Sites\ridemo>git add .
fatal: Not a git repository (or any of the parent directories): .git

What to do?

Thanks in advance,

You probably need to designate that directory as a git repository first.

git init

That did it. Thanks.

New problem…

C:\Sites\ridemo>git init
Initialized empty Git repository in C:/Sites/ridemo/.git/

C:\Sites\ridemo>git add .

C:\Sites\ridemo>git commit “Initial.”
error: pathspec ‘Initial.’ did not match any file(s) known to git.

If you prefer to do these things through GUI, then use “git gui”, it
open up a nice gui for you where you can select which files should be
committed, specify the commit comments, commit and push to the server.

git commit -m “Initial.”

On Thu, Jun 30, 2011 at 1:38 PM, [email protected]

For lack of a better idea, I just skipped over that error and went on
to the next step. Now I have the one below…

C:\Sites\ridemo>gh create-from-local
=> error creating repository

C:\Sites\ridemo>git remote add origin [email protected]:friendlyfriend/

C:\Sites\ridemo>git push -u origin master
The authenticity of host ‘github.com (’ can’t be
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘github.com,’ (RSA) to the
list of know
n hosts.
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

‘clip’ is not recognized as an internal or external command,
operable program or batch file.
Your public ssh key has been copied to your clipboard.


It says, “Your public ssh key has been copied to your clipboard”, but
the public key is not copied to the clipboard.

So I decided to go through this process for setting the key described
on the github site…

…That all went well, but it still gives me the same error:

C:\Sites\ridemo>git push -u origin master
Permission denied (publickey).
fatal: The remote end hung up unexpectedly


Thanks. git commit -m “Initial.” worked. I had left out the “m”.

Now I’m stuck here…

C:\Sites\ridemo>gh create-from-local
=> error creating repository

git gui starts the gui, but I’m not sure what to do after it starts.
I don’t know which files should be committed or how to accomplish the
goal of “gh create-from-local” or how to get something to appear in
the empty boxes

On Jul 23, 10:38pm, “[email protected][email protected]

You need to upload your public key to GitHub.

That should be inside .ssh directory in your user folder.

Luis L.

sir i m stuck at
gh create-from-local and i got an error "c:/rails
1.9.2/lib/ruby/1.9.1/open.rb:202: in ‘spawn’: no such file or

what i ll do?

Where your ssh dir is, aber depends on your version of windows, the used
ssh client and if you are using cygwin or msys or non of them.

So please give some more details about your environment.
Am 29.10.2012 15:47 schrieb “Colm Ginty” [email protected]:

I wonder if you could tell me how to find the ‘ssh directory’. I’ve
and looked and can’t find the key in my RoR files. I have the same
where the command prompt line told me that the ssh key had copied to my
clipboard but in fact it hadn’t.

Install github for Windows so it will manage your keys and everything
for you automatically, it’s truly the easiest way to Work with git on
Windows if it’s your first time with Git.

Thanks Norbert and Jordan, I found the ssh directory. I realise in
hindsight that I should have done some more searching before I posted
question. I’m still getting the hang of this software lark (I’m a
beginner!) I am working with GitHub, although I’m having some serious
trouble syncing my system up with the online repository. I will work at
though, and perhaps post a question if I can’t make any progress. Thanks
again for your help guys.

On 29 October 2012 17:28, Jordon B. [email protected] wrote:

So please give some more details about your environment.

On Sunday, July 24, 2011 9:15:12 PM UTC+1, Luis L. wrote:

C:\Sites\ridemo>git push -u origin master

Ice cleats to slip over normal shoes.


No more slipping on snow and ice! Cheap and high quality compared to the