Rails installation


#1

Hi,

I am new to Rails. I installed ruby in my system and when I try to
install rails it is giving error and later I realized that my proxy
server is blocking the rails gem download. So I downloaded the
rails2.1 gem and what is the gem install command to install rails.

Please help me I am totally on hold because of this. Expecting a
quick reply :slight_smile:

Thanks,
Ramu.


#2

On Oct 5, 8:46 am, “removed_email_address@domain.invalid” removed_email_address@domain.invalid wrote:

Hi,

I am new to Rails. I installed ruby in my system and when I try to
install rails it is giving error and later I realized that my proxy
server is blocking the rails gem download. So I downloaded the
rails2.1 gem and what is the gem install command to install rails.

gem help install should help you out.

Fred


#3

I did that. But it was asked for rake 0.8 then I installed rake. Now
it is asking for Active support. Is there any package with all the
gems??

Thanks,
Ramu.

On Oct 5, 5:00 pm, Frederick C. removed_email_address@domain.invalid


#4

Not sure if this will help, but gems will traverse a proxy server if you
tell it where to go by setting an environment variable like so:

http_proxy=http://win_username:removed_email_address@domain.invalid:port_number

So for me it’d be something like:

http_proxy=http://win_username:removed_email_address@domain.invalid:8080

I normally set that manually on a command line & then issue the
appropriate gem command.

HTH,

-Roy