Rails installation - incompatible rake?


#1

What do I need to do inorder to install rails? - Thx -ND

C:>gem install rails
Attempting local installation of ‘rails’
ERROR: Error installing gem rails[.gem]: rails requires rake >= 0.6.2

C:>gem install rails-1.0.0.gem
Attempting local installation of ‘rails-1.0.0.gem’
ERROR: Error installing gem rails-1.0.0.gem[.gem]: rails requires rake


#2

Nirav wrote:

What do I need to do inorder to install rails? - Thx -ND

C:>gem install rails
Attempting local installation of ‘rails’
ERROR: Error installing gem rails[.gem]: rails requires rake >= 0.6.2

C:>gem install rails-1.0.0.gem
Attempting local installation of ‘rails-1.0.0.gem’
ERROR: Error installing gem rails-1.0.0.gem[.gem]: rails requires rake

The rails gem has dependencies on a number of other gems. When
installed from the net, the dependencies are resolved automatically.
When you install a local .gem file, you must get all the dependent gems
as well and install them first.

If you have net access, the easiest way is to use the command:

gem install rails --include-dependencies --remote


– Jim W.