Rails Framework

When I try to create new rails framework I’ getting the follow error.
I’ve had to reinstall ruby and ruby gem.

/Library/Ruby/Site/1.8/rubygems.rb:149:in activate': can't activate activesupport (= 2.1.0, runtime), already activated activesupport-2.2.2 (Gem::Exception) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:inrequire’
from /Users/brianspadetti/.gem/ruby/1.8/gems/rails-2.2.2/bin/…/lib/
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from /Users/brianspadetti/.gem/ruby/1.8/gems/rails-2.2.2/bin/rails:13
from /usr/bin/rails:19:in `load’
from /usr/bin/rails:19
Please help


ruby -v
gem -v
gem list

ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9]
gem -v 1.3.1

actionmailer (2.2.2, 2.1.0)
actionpack (2.2.2, 2.1.0)
activerecord (2.2.2, 2.1.0)
activeresource (2.2.2, 2.1.0)
activesupport (2.2.2, 2.1.0)
acts_as_ferret (0.4.3)
addressable (2.0.2)
capistrano (2.5.4)
daemons (1.0.10)
data_objects (0.9.11)
dnssd (0.7.0)
extlib (0.9.10)
ferret (0.11.6)
highline (1.5.0)
hpricot (0.6.164)
libxml-ruby (0.9.8)
mongrel (1.1.5)
net-scp (1.0.2)
net-sftp (2.0.2)
net-ssh (2.0.10)
net-ssh-gateway (1.0.1)
rails (2.2.2, 2.1.0)
rake (0.8.3)
RedCloth (4.1.1)
ruby-openid (2.1.4)
rubynode (0.1.5)

should I remove or downgrade any versions that are 2.2.2? If so how
would I uninstall and reinstall because I installed everything threw

I believe I had a similar problem once, either caused by multiple
versions of Rails installed or by having some version of Rails frozen
into vendor/rails

My solution was to remove the offending version since I wasn’t locked
to a specific version.

I figured it out. Thank you for your help. Issues I had was I install
under gem and tried to remove it. Then I tried to install in macports
cause the issues because ruby was making references to other instances
that makes sense?