Rails failure after upgrade to 1.1.2

I tried upgrading Rails to 1.1.2 and now nothing is really working. In
connection to the Rails upgrade I upgraded my Ruby version to 1.9.0. I
also upgraded all my gem installs.

Since my old rails apps stopped working I tried generating a fresh one
, alas with the same result. Below I included the full trace when
trying to reach the app. Line 3 in application.rb is :

class ApplicationController < ActionController::Base

Any hints on where I might be going wrong is much appreciated,

–Full trace from browser–

match' /usr/lib/ruby/gems/1.9/gems/actionwebservice-1.1.2/lib/action_web_service/container/action_controller_container.rb:66:inrequire_web_service_api’
web_service_api_with_require' /usr/lib/ruby/gems/1.9/gems/actionwebservice-1.1.2/lib/action_web_service/container/action_controller_container.rb:87:ininherited_with_api’
inherited_with_action_controller' #{RAILS_ROOT}/app/controllers/application.rb:3 /usr/lib/ruby/gems/1.9/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:inload’
require_or_load' /usr/lib/ruby/gems/1.9/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:30:independ_on’
require_dependency' /usr/lib/ruby/gems/1.9/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:85:inrequire_dependency’
prepare_application' /usr/lib/ruby/gems/1.9/gems/rails-1.1.2/lib/dispatcher.rb:37:indispatch’
handle_dispatch' /usr/lib/ruby/gems/1.9/gems/rails-1.1.2/lib/webrick_server.rb:81:inservice’
/usr/lib/ruby/1.9/webrick/httpserver.rb:111:in service' /usr/lib/ruby/1.9/webrick/httpserver.rb:70:inrun’
/usr/lib/ruby/1.9/webrick/server.rb:172:in `start_thread’

This error occured while loading the following files:

I’m not sure that Rails 1.1.2 is compatible with Ruby 1.9

On 4/11/06, Kristofer L. [email protected] wrote:

web_service_api_with_require' depend_on’
/usr/lib/ruby/1.9/webrick/httpserver.rb:111:in `service’


It happens with 1.8.4 as well

OK. Can you post besides the stack trace what exception is being
thrown? Thanks.


On 4/11/06, Shane S. [email protected] wrote:

also upgraded all my gem installs.
–Full trace from browser–


[email protected]
[email protected]


I decided on downgrading to ruby 1.8.2 for the moment. Have the same
gem install , so I get to run rails 1.1.2, and everything works just
fine again.

Hey Kristofer, I would have gone with Ruby 1.8.4 instead of 1.8.2 for
RoR development.


Ok, this is where the exception is caught.

(500 Internal Error)

Can you show us the stack trace from the log file, not from the browser?

From the information you’ve provided I can see what the problem is.



The reason I went as far back as to 1.8.2 was that Shane seemd to have
the same problem on 1.8.4. However I would prefer using 1.8.4 so I can
run mongrel. WIll test and see if I run into the same issues.



I did post the only line that differed from my logfile and the output
the browser gave me. However I now run 1.8.4 and all is still ok.
Myhaps there is something not ready for ruby 1.9.0 in rails.

I’ll just repost the log error again for your convenice
(500 Internal Error)