Rails Error

I’m totally new with ruby on rails
My machine running ubuntu 8.10 and i have installed ruby 1.8.7,
rubygems 1.3.1 and rails 2.3.2, sqlite3, postfix adn subversion.
The problem is when i want to create a simple blog application this
error came out.
[email protected]:~$ sudo rails blog
/var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/active_support/
core_ext/uri.rb:8:in <top (required)>': uninitialized constant URI::Parser (NameError) from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/active_support/ core_ext.rb:3:inrequire’
from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/active_support/
core_ext.rb:3:in block in <top (required)>' from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/active_support/ core_ext.rb:1:ineach’
from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/active_support/
core_ext.rb:1:in <top (required)>' from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/ active_support.rb:55:inrequire’
from /var/lib/gems/1.9.0/gems/activesupport-2.3.2/lib/
active_support.rb:55:in <top (required)>' from /var/lib/gems/1.9.0/gems/rails-2.3.2/lib/rails_generator.rb: 28:inrequire’
from /var/lib/gems/1.9.0/gems/rails-2.3.2/lib/rails_generator.rb:
28:in <top (required)>' from /var/lib/gems/1.9.0/gems/rails-2.3.2/bin/rails:14:inrequire’
from /var/lib/gems/1.9.0/gems/rails-2.3.2/bin/rails:14:in <top (required)>' from /usr/bin/rails:19:inload’
from /usr/bin/rails:19:in `’
[email protected]:~$
Help me please.
Regards.
Fadil

On Apr 15, 4:55 am, fadil [email protected] wrote:

I’m totally new with ruby on rails
My machine running ubuntu 8.10 and i have installed ruby 1.8.7,
rubygems 1.3.1 and rails 2.3.2, sqlite3, postfix adn subversion.
The problem is when i want to create a simple blog application this
error came out.

That stack trace looks you are using ruby 1.9.0 which you almost
certainly don’t want to use (1.9.0 was the development version of what
was eventually released as ruby 1.9.1)

Fred