Rails deployment


#1

Hi all,

I’ve greated a rails application and i want to deploy it right now.
I have to use a windows 2003 server… So i installed

i’ve used the following tutorial:

http://wiki.rubyonrails.com/rails/pages/RailsOnWindows

My application is running at : http://loc.iwsweb.nl

But everytime i connect it opens a ruby process but at the end it won’t
kill it.

As you can see the loading speed is horrible, but it’s a fast server
with a 100mbit connection.

Can anyone help me?

Thanks in advance,

Daan


#2

Daan wrote:

Hi all,

I’ve greated a rails application and i want to deploy it right now.
I have to use a windows 2003 server… So i installed

i’ve used the following tutorial:

http://wiki.rubyonrails.com/rails/pages/RailsOnWindows

My application is running at : http://loc.iwsweb.nl

But everytime i connect it opens a ruby process but at the end it won’t
kill it.

As you can see the loading speed is horrible, but it’s a fast server
with a 100mbit connection.

Can anyone help me?

Thanks in advance,

Daan

Are you using Apache or Lighty?

Please post your .htaccess and the part of your httpd.conf that you
modified

P
http://wiki.onrails.com.ar


#3

I’m using Apache

htaccess:
AddHandler fastcgi-script .fcgi
AddHandler cgi-script .cgi
Options +FollowSymLinks +ExecCGI

RewriteEngine On

RewriteRule ^$ index.html [QSA]
RewriteRule ^([^.]+)$ $1.html [QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

httpd.conf:

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule fastcgi_module modules/mod_fastcgi.dll

DocumentRoot “C:/rails_docs/locaties/public”
<Directory “C:/rails_docs/locaties/public”>

<VirtualHost *:80>
ServerName rails
DocumentRoot “C:/rails_docs/locaties/public”
<Directory “C:/rails_docs/locaties/public”>
Options ExecCGI FollowSymLinks
AllowOverride all
Allow from all
Order allow,deny
AddHandler cgi-script .cgi
AddHandler fastcgi-script .fcgi


#4

Daan wrote:

I’m using Apache

htaccess:
AddHandler fastcgi-script .fcgi
AddHandler cgi-script .cgi
Options +FollowSymLinks +ExecCGI

RewriteEngine On

RewriteRule ^$ index.html [QSA]
RewriteRule ^([^.]+)$ $1.html [QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

httpd.conf:

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule fastcgi_module modules/mod_fastcgi.dll

DocumentRoot “C:/rails_docs/locaties/public”
<Directory “C:/rails_docs/locaties/public”>

<VirtualHost *:80>
ServerName rails
DocumentRoot “C:/rails_docs/locaties/public”
<Directory “C:/rails_docs/locaties/public”>
Options ExecCGI FollowSymLinks
AllowOverride all
Allow from all
Order allow,deny
AddHandler cgi-script .cgi
AddHandler fastcgi-script .fcgi

IMHO Seems to be ok.

Ive readed that there are some issues with apache and fcgi. Search
google about that.
Lighttpd has better performance. Try lighty have you?
I used ligthy on my w2000 box.

P

http://wiki.onrails.com.ar