Rails application failed to start properly

Buenas estoy intentando migrar de mi maquina al servidor de dreamhost
pero
me da este error
Rails application failed to start properlyLo que mas raro me parece que
miro
en los logs y lo encuentro vacio, alguien sabe porque pasa esto?

Utilizo servidor dreamhost

gracias

  Francisco José Blanco Montero

==============================

Ves al raíz de tu proyecto y ejecuta public/dispatch.fcgi, que así
veras los errores que provocan que no arranque.

He modificado el config/database.yml Y ahora me salen estos errores

/usr/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
load' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:innew_constants_in’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
load' from /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/routing.rb:1165:inload_routes!’
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/routing.rb:1157:in
reload' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:287:ininitialize_routing’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:111:in
process' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:insend’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
run' from ./public/../config/environment.rb:14 from public/dispatch.fcgi:21:inrequire’
from public/dispatch.fcgi:21


2007/6/10, Fran B. [email protected]n.invalid:

`process’

que miro

Fernando B.
==============================
Francisco José Blanco Montero

==============================

  Francisco José Blanco Montero

==============================

Oks Gracias, en el log me sale esto:
/usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/abstract/connection_specification.rb:204:in
establish_connection': production database is not configured (ActiveRecord::AdapterNotSpecified) from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/abstract/connection_specification.rb:195:inestablish_connection’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:229:in
initialize_database' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:88:inprocess’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
send' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:inrun’
from ./public/…/config/environment.rb:14
from public/dispatch.fcgi:21:in `require’
from public/dispatch.fcgi:21

El día 10/06/07, Fernando B. [email protected] escribió:

en los logs y lo encuentro vacio, alguien sabe porque pasa esto?

blog > http://www.inwebwetrust.net


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

  Francisco José Blanco Montero

==============================

Hmmmm, ¿puede que te hayas dejado cosas al pegar el error?

Y también podrías pegar tu fichero de rutas, aunque ahora ya no sé si
el problema
está ahí.

E inicializado por webrick y sale esto:

/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:in
load': ./script/../config/../config/routes.rb:21: syntax error, unexpected tIDENTIFIER, expecting kEND (SyntaxError) map.connect ':controller =>'principal',:action => 'login' ^ ./script/../config/../config/routes.rb:21: syntax error, unexpected tIDENTIFIER, expecting kEND map.connect ':controller =>'principal',:action => 'login' ^ ./script/../config/../config/routes.rb:22: syntax error, unexpected ':', expecting kEND map.connect ':controller/service.wsdl', :action => 'wsdl' ^ ./script/../config/../config/routes.rb:22: syntax error, unexpected tSTRING_BEG, expecting kEND map.connect ':controller/service.wsdl', :action => 'wsdl' ^ ./script/../config/../config/routes.rb:22: syntax error, unexpected tIDENTIFIER, expecting kEND map.connect ':controller/service.wsdl', :action => 'wsdl' ^ ./script/../config/../config/routes.rb:26: syntax error, unexpected ':', expecting kEND map.connect ':controller/:action/:id' ^ ./script/../config/../config/routes.rb:26: syntax error, unexpected tSTRING_BEG, expecting kEND map.connect ':controller/:action/:id' ^ ./script/../config/../config/routes.rb:26: unterminated string meets end of filefrom /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:inload’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:in
new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:488:inload’
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/routing.rb:1165:in
load_routes!' from /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/routing.rb:1157:inreload’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:287:in
initialize_routing' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:111:inprocess’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
send' ... 13 levels... from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3 /lib/commands/server.rb:39 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from script/server:3

Y mi fichero de rutas:

map.home ‘/’, :controller => ‘principal’, :action => ‘login’

map.connect :controller =>‘principal’,:action => ‘login’

map.connect ‘:controller/service.wsdl’, :action => ‘wsdl’

Install the default route as the lowest priority.

map.connect ‘:controller/:action/:id’

end

El día 10/06/07, Fernando B. [email protected] escribió:


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

  Francisco José Blanco Montero

==============================

A la segunda llamada al map.connect le falta el parámetro string con
la ruta, es decir:

Tú tienes puesto:

map.connect :controller =>‘principal’,:action => ‘login’

Y debería ser algo
así:
map.connect ‘/login’, :controller =>‘principal’,:action => ‘login’

Inténtalo a ver…

Sips ahora si que va, muchas gracias, ahora me arranca con Webrick, pero
sigue sin funcionar por el arranque que tiene dreamhost.

Pero en el public/dispatch.fcgi no sale nada y en los logs no veo ningu
error

Bueno y gracias eh :stuck_out_tongue:

2007/6/10, Fernando B. [email protected]:

map.connect ‘/login’, :controller =>‘principal’,:action => ‘login’

`load’: ./script/…/config/…/config/routes.rb:21: syntax
^
map.connect ‘:controller/:action/:id’
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2
from
from

end

El día 10/06/07, Fernando B. <[email protected] > escribió:


Fernando B.
blog > http://www.inwebwetrust.net


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

  Francisco José Blanco Montero

==============================

2007/6/10, Fran B. [email protected]:

Ya funciona, Dreamhost requiere 5 a 10 min para habilitarlo jeje

Muchas veces en Dreamhost tarda en arrancar una aplicación Rails que
esté perfecta, ellos son así. Tienes que darle al botón de actualizar
el navegador muchas veces mientras haces el sonido de un coche
arrancando, “brrrooomm, brrrooooommmm”, hasta que deja de salir ese
“failed to start properly” XDDD

Ya funciona, Dreamhost requiere 5 a 10 min para habilitarlo jeje

Gracias

2007/6/10, Fran B. [email protected]:

Tú tienes puesto:
On 6/10/07, Fran B. <[email protected] > wrote:

unexpected tIDENTIFIER, expecting kEND
./script/…/config/…/config/routes.rb:22: syntax error,
^
from
from
`require’
map.connect ‘:controller/service.wsdl’, :action => ‘wsdl’

si

[email protected]
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

  Francisco José Blanco Montero

==============================

  Francisco José Blanco Montero

==============================

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs