Rails and MySQL 5.0


#1

Is rails dependent on database versions?
Before I start setting it all up, I would like to know if it is possbile
to run Rails with MySQL 5.0?

Thanks,

Matthew Bennett


#2

I have no problem running my rails apps with mysql5.

However, you could have problems with the different password hashing
algorithms when connecting to the mysql server, in case you are
upgading from an older (3.x or 4.1.11 or lower) version.

If that is the case, you can find information about using old style
passwords here:

http://dev.mysql.com/doc/refman/5.0/en/old-client.html

I hope this helps.

Cheers,
Andras