Rails 3: bundle install vendor - ffi 0.5.4 gem crashes : ERROR: Failed to build gem native extensio

Installing ffi (0.5.4) from rubygems repository at http://gemcutter.org
with native extensions /usr/local/Cellar/ruby/1.9.1-p378/lib/ruby/
site_ruby/1.9.1/rubygems/installer.rb:504:in `rescue in block in
build_extensions’: ERROR: Failed to build gem native extension.
(Gem::Installer::ExtensionBuildError)

rake RUBYARCHDIR=/Users/kristianconsult/my_rails/rails3_apps/demo_app/
vendor/gems/ffi-0.5.4/lib RUBYLIBDIR=/Users/kristianconsult/my_rails/
rails3_apps/demo_app/vendor/gems/ffi-0.5.4/lib
/usr/local/Cellar/ruby/1.9.1-p378/lib/ruby/site_ruby/1.9.1/rubygems.rb:
827:in report_activate_error': Could not find RubyGem rake (>= 0) (Gem::LoadError) from /usr/local/Cellar/ruby/1.9.1-p378/lib/ruby/site_ruby/1.9.1/ rubygems.rb:261:inactivate’
from /usr/local/Cellar/ruby/1.9.1-p378/lib/ruby/site_ruby/1.9.1/
rubygems.rb:68:in gem' from <internal:gem_prelude>:273:inpush_gem_version_on_load_path’
from internal:gem_prelude:14:in gem' from /usr/local/bin/rake:18:in

How can I resolve this?

Gemfile

git “git://github.com/rails/arel.git”
git “git://github.com/rails/arel.git”
git “git://github.com/rails/rack.git”
git “git://github.com/rspec/rspec.git”
git “git://github.com/negonicrac/rspec-rails.git”
git “git://github.com/kristianmandrup/cucumber-rails.git”

gem “rails”, “3.0.0.beta1”, :git => “git://github.com/rails/rails.git”

source :gemcutter
source “http://gems.github.com

gem “sqlite3-ruby”
gem “rspec-rails”, “2.0.0.a4”
gem “rspec”, “2.0.0.a4”
gem ‘database_cleaner’, ‘>=0.4.3’
gem ‘capybara’, ‘>=0.3.0’
gem ‘cucumber’
gem ‘cucumber-rails’, ‘0.2.5’
gem “webrat”

Thanks :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs