Rails 3.2.1

hi guys,where can i download rails 3.2.1, i dont like rails 4.0 and
thats
the version which railsinstaller.org offers now.pls help

On Thursday, December 26, 2013 5:34:39 AM UTC, pavey nganpi wrote:

hi guys,where can i download rails 3.2.1, i dont like rails 4.0 and thats the
version which railsinstaller.org offers now.pls help

gem install rails --version 3.2.1

Should allow you to set your rails version, or (in an already existing
app) you can specify the rails version to use Gemfile.

You should use a more recent version of 3.2 than 3.2.1 since that
version has a remote code execution vulnerability. Also if you are
starting out with a new app I would start with rails 4 - you’ll have to
migrate to it at some point and it’s easiest to do that right off the
bat.

Fred

You don’t mention what you don’t like about 4 – there are flags you can
set at app generation time to turn off features, substitute Prototype
for jQuery, whatever floats your boat. I have a lot of issues with the
asset pipeline, but 3.2 shares them as well, so it’s hard to say what
your specific issue is with 4. (You can turn off turbolinks, too!)

Walter

When generating my first status, that is when I do the
localhost/statuses I
have the following error:

ExecJS::RuntimeError in Statuses#index
Showing
C:/Users/NEBELYN/ruby1/gopbook/app/views/layouts/application.html.erb
where line #6 raised:
(in
C:/Users/NEBELYN/ruby1/gopbook/app/assets/javascripts/statuses.js.coffee)
Extracted source (around line #6):
3: 4: Gopbook 5: <%= stylesheet_link_tag “application”, :media => “all”
%> 6: <%= javascript_include_tag “application” %> 7: <%= csrf_meta_tags
%> 8: 9: Rails.root: C:/Users/NEBELYN/ruby1/gopbook

HERE IS MY GEM FILE

source ‘https://rubygems.org

gem ‘rails’, ‘3.2.16’

Bundle edge Rails instead:# gem ‘rails’, :git =>

‘git://github.com/rails/rails.git’

gem ‘sqlite3’

Gems used only for assets and not required# in production environments

by default.
group :assets do
gem ‘sass-rails’, ‘~> 3.2.3’
gem ‘coffee-rails’, ‘~> 3.2.1’

See https://github.com/sstephenson/execjs#readme for more supported

runtimes

gem ‘therubyracer’, :platforms => :ruby

gem ‘uglifier’, '>= 1.0.3’end

gem ‘jquery-rails’

To use ActiveModel has_secure_password# gem ‘bcrypt-ruby’, ‘~> 3.0.0’

To use Jbuilder templates for JSON# gem ‘jbuilder’

Use unicorn as the app server# gem ‘unicorn’

Deploy with Capistrano# gem ‘capistrano’

To use debugger# gem ‘debugger’

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs